summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-11-30 14:44:49 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-11-30 14:44:49 +0100
commitf6c827c1c9ecc3dedd584d47d05ed6faa24e33ab (patch)
tree3297de95500c607130d89ef7fa79532ad125057c /gnu/packages/wm.scm
parent52828db08352c16518769538b7923c803a9b87ec (diff)
downloadguix-patches-f6c827c1c9ecc3dedd584d47d05ed6faa24e33ab.tar
guix-patches-f6c827c1c9ecc3dedd584d47d05ed6faa24e33ab.tar.gz
gnu: Add sbcl-stumpwm-winner-mode.
* gnu/packages/wm.scm (sbcl-stumpwm-winner-mode): New variable.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 4c11ce81f2..36eb58b713 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1946,6 +1946,25 @@ layouts in StumpWM.")
(description "Modeline support for memory info.")
(license license:gpl3+)))
+(define-public sbcl-stumpwm-winner-mode
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-winner-mode")
+ (arguments
+ '(#:asd-systems '("winner-mode")
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "util/winner-mode"))))))
+ (home-page
+ "https://github.com/stumpwm/stumpwm-contrib/tree/master/util/winner-mode")
+ (synopsis "Emacs' winner-mode for StumpWM")
+ (description "This module provides a winner-mode for StumpWM similar to the
+one in Emacs.")
+ (license license:gpl3+)))
+
(define-public lemonbar
(let ((commit "35183ab81d2128dbb7b6d8e119cc57846bcefdb4")
(revision "1"))