summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-19 23:52:45 +0100
committerMarius Bakke <marius@gnu.org>2020-11-20 00:10:11 +0100
commitf5fb52f14792a3ede1e79c302895dcaf73e9d7c8 (patch)
treed1dc3784a64cafedef9b982ba5a5c07f3a453b0a /gnu/packages/wm.scm
parent35ed83beae51c05069ed6754dd26cf0f549808ab (diff)
downloadguix-patches-f5fb52f14792a3ede1e79c302895dcaf73e9d7c8.tar
guix-patches-f5fb52f14792a3ede1e79c302895dcaf73e9d7c8.tar.gz
gnu: wlroots: Update to 0.12.0.
* gnu/packages/wm.scm (wlroots): Update to 0.12.0. [arguments]: Add #:meson. Adjust Xwayland substitution in #:phases. [inputs]: Move everything ... [propagated-inputs]: ... here. Add XCB-UTIL-ERRORS and XCB-UTIL-WM. [native-inputs]: Remove FFMPEG, LIBCAP, and LIBPNG.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm38
1 files changed, 21 insertions, 17 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 9cdaf864af..64b9b2ade5 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
;;; Copyright © 2016 Ivan Vilata i Balaguer <ivan@selidor.net>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
-;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019, 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
@@ -72,6 +72,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages build-tools) ;for meson-0.55
#:use-module (gnu packages calendar)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
@@ -1342,7 +1343,7 @@ functionality to display information about the most commonly used services.")
(define-public wlroots
(package
(name "wlroots")
- (version "0.10.1")
+ (version "0.12.0")
(source
(origin
(method git-fetch)
@@ -1351,32 +1352,35 @@ functionality to display information about the most commonly used services.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0j2lh9vc92zhn44rjbia5aw3y1rpgfng1x1h17lcvj5m4i6vj0pc"))))
+ (base32 "01j38lmgs2c6fq68v8b75pkilia2wsgzgp46ivfbi9hhx47kgcfn"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dlogind-provider=elogind")
+ #:meson ,meson-0.55
#:phases
(modify-phases %standard-phases
(add-before 'configure 'hardcode-paths
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "xwayland/xwayland.c"
+ (substitute* "xwayland/server.c"
(("Xwayland") (string-append (assoc-ref inputs
"xorg-server-xwayland")
"/bin/Xwayland")))
#t)))))
- (inputs `(("elogind" ,elogind)
- ("eudev" ,eudev)
- ("libinput" ,libinput)
- ("libxkbcommon" ,libxkbcommon)
- ("mesa" ,mesa)
- ("pixman" ,pixman)
- ("wayland" ,wayland)
- ("xorg-server-xwayland" ,xorg-server-xwayland)))
- (native-inputs `(("ffmpeg" ,ffmpeg)
- ("libcap" ,libcap)
- ("libpng" ,libpng)
- ("pkg-config" ,pkg-config)
- ("wayland-protocols" ,wayland-protocols)))
+ (propagated-inputs
+ `(;; As required by wlroots.pc.
+ ("elogind" ,elogind)
+ ("eudev" ,eudev)
+ ("libinput" ,libinput)
+ ("libxkbcommon" ,libxkbcommon)
+ ("mesa" ,mesa)
+ ("pixman" ,pixman)
+ ("wayland" ,wayland)
+ ("xcb-util-errors" ,xcb-util-errors)
+ ("xcb-util-wm" ,xcb-util-wm)
+ ("xorg-server-xwayland" ,xorg-server-xwayland)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("wayland-protocols" ,wayland-protocols)))
(home-page "https://github.com/swaywm/wlroots")
(synopsis "Pluggable, composable, unopinionated modules for building a
Wayland compositor")