summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorphodina <phodina@protonmail.com>2021-08-17 16:49:55 +0000
committerLudovic Courtès <ludo@gnu.org>2021-09-13 12:31:11 +0200
commitec0e05ff306c950142c9ead7c712c749617069e7 (patch)
treed2bc517d133c1df01286df4d8aa63bb088695993 /gnu/packages/wm.scm
parent49658fc66fd365e808105e5ef674b0b408775a15 (diff)
downloadguix-patches-ec0e05ff306c950142c9ead7c712c749617069e7.tar
guix-patches-ec0e05ff306c950142c9ead7c712c749617069e7.tar.gz
gnu: Add i3lock-blur.
* gnu/packages/wm.scm (i3lock-blur): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 97dfd1eff5..957c5a0d5a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -411,6 +412,43 @@ from many programming languages.")
Despite the name it should work with any X11 window manager.")
(license license:bsd-3)))
+(define-public i3lock-blur
+ (package
+ (name "i3lock-blur")
+ (version "2.10")
+ (source (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/karulont/i3lock-blur")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bd5nrlga5g1sz1f64gnc3dqy8yfrr4q1ss59krymbpxa1hhf55c"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("automake" ,automake)
+ ("autoconf" ,autoconf)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("mesa" ,mesa)
+ ("libev" ,libev)
+ ("linux-pam" ,linux-pam)
+ ("libxcb" ,libxcb)
+ ("libxkbcommon" ,libxkbcommon)
+ ("xcb-util" ,xcb-util)
+ ("xcb-util-image" ,xcb-util-image)
+ ("xcb-util-xrm" ,xcb-util-xrm)))
+ (home-page "https://github.com/karulont/i3lock-blur")
+ (synopsis "Lightweight screen locker with transparent blurring background")
+ (description
+ "Simple X11 screen locker with transparent blurring background developed
+alongside the i3 project. Despite the name it should work with any X11 window
+manager.")
+ (license license:expat)))
+
(define-public i3blocks
(package
(name "i3blocks")