summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-11-22 15:33:43 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-11-22 15:35:47 +0000
commite711ad31857c587194c3077d2f1bb08c2124e8cd (patch)
treea02ef5aa9ff110f59445744cea3916a5bedb9a67 /gnu/packages/wm.scm
parent18ab016be1f1846254b054fa937b539487d2bbdb (diff)
downloadguix-patches-e711ad31857c587194c3077d2f1bb08c2124e8cd.tar
guix-patches-e711ad31857c587194c3077d2f1bb08c2124e8cd.tar.gz
gnu: awesome: Fix build.
* gnu/packages/patches/awesome-4.3-fno-common.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/wm.scm (awesome)[source]: Use it. [arguments]{set-paths}: Set HOME and XDG_CACHE_HOME variables.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 6361530534..176c1bf36c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1011,7 +1011,8 @@ for wlroots-based Wayland compositors.")
"\"~c\"")))
#t))
(patches
- (search-patches "awesome-reproducible-png.patch"))))
+ (search-patches "awesome-reproducible-png.patch"
+ "awesome-4.3-fno-common.patch"))))
(build-system cmake-build-system)
(native-inputs
`(("asciidoc" ,asciidoc)
@@ -1093,7 +1094,8 @@ for wlroots-based Wayland compositors.")
(setenv "LD_LIBRARY_PATH" cairo)
(setenv "LUA_PATH" (string-append "?.lua;" lua-path))
(setenv "LUA_CPATH" lua-cpath)
- #t)))
+ (setenv "HOME" (getcwd))
+ (setenv "XDG_CACHE_HOME" (getcwd)))))
(replace 'check
(lambda _
;; There aren't any tests, so just make sure the binary