summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
commite3196755e60ba7f1ed9d432e73f26a85e0c8893c (patch)
tree06bc27447f2f72b20a2be0201b41b964af03fc87 /gnu/packages/wm.scm
parentfc9ca46aa6403c90e2ea5c815d813d2dba162dfb (diff)
downloadguix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar
guix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar.gz
gnu: Further simplify package inputs.
This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.)
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm34
1 files changed, 15 insertions, 19 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 65c040cd92..20f9abec67 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1216,8 +1216,7 @@ all of them. Currently supported window managers include:
"0h52hj3ay8mfhwvmfxbxlfyq74hifdk8wxgxp7fr4iy6189hg7w7"))))
(build-system gnu-build-system)
(inputs
- `(("python-2" ,python-2)
- ("gtk+-2" ,gtk+-2)))
+ (list python-2 gtk+-2))
(native-inputs
(list python2-pygtk gtk-doc pkg-config))
(synopsis "Library for registering global keyboard shortcuts")
@@ -1699,24 +1698,21 @@ display a clock or apply image manipulation techniques to the background image."
(sha256
(base32 "109a49f064ma5js2d7maribmfalswbmmhq2fraa7hfz5pf2jxs2w"))))
(build-system meson-build-system)
- (inputs `(("date" ,date)
- ("fmt" ,fmt)
- ("gtk-layer-shell" ,gtk-layer-shell)
- ("gtkmm" ,gtkmm-3)
- ("jsoncpp" ,jsoncpp)
- ("libdbusmenu" ,libdbusmenu)
- ("libinput" ,libinput)
- ("libmpdclent" ,libmpdclient)
- ("libnl" ,libnl)
- ("libxml2" ,libxml2)
- ("pulseaudio" ,pulseaudio)
- ("spdlog" ,spdlog)
- ("wayland" ,wayland)))
+ (inputs (list date
+ fmt
+ gtk-layer-shell
+ gtkmm-3
+ jsoncpp
+ libdbusmenu
+ libinput
+ libmpdclient
+ libnl
+ libxml2
+ pulseaudio
+ spdlog
+ wayland))
(native-inputs
- `(("glib:bin" ,glib "bin")
- ("pkg-config" ,pkg-config)
- ("scdoc" ,scdoc)
- ("wayland-protocols" ,wayland-protocols)))
+ (list `(,glib "bin") pkg-config scdoc wayland-protocols))
(home-page "https://github.com/Alexays/Waybar")
(synopsis "Wayland bar for Sway and Wlroots based compositors")
(description "Waybar is a highly customisable Wayland bar for Sway and