summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-11-14 01:32:38 -0800
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:51 -0500
commitb066ad895d9f3d7c30208825d5f4d3b5bec697cc (patch)
tree81f27b8e64f63625affced784ef6031e782e03af /gnu/packages/wm.scm
parentd05f32d6f4d4a7c1ffc268a74993fe3be72e4b93 (diff)
downloadguix-patches-b066ad895d9f3d7c30208825d5f4d3b5bec697cc.tar
guix-patches-b066ad895d9f3d7c30208825d5f4d3b5bec697cc.tar.gz
gnu: Update xmobar to 0.31.
* gnu/packages/wm.scm (xmobar): Update to 0.31. [arguments]: Remove the previous configure flags and set the 'all_extensions' flag; add a 'patch-test-shebang' phase. [inputs]: Add 'ghc-alsa-core', 'ghc-alsa-mixer', 'ghc-dbus', 'ghc-http-conduit', 'ghc-http-types', 'ghc-libmpd', 'ghc-old-locale', 'ghc-temporary', 'ghc-timezone-olson', and 'ghc-x11'. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm34
1 files changed, 22 insertions, 12 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 080b0f32a6..87e62aa1aa 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019 Kyle Andrews <kyle.c.andrews@gmail.com>
;;; Copyright © 2019 Ingo Ruhnke <grumbel@gmail.com>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -649,36 +650,45 @@ tiled on several screens.")
(define-public xmobar
(package
(name "xmobar")
- (version "0.28")
+ (version "0.31")
(source (origin
(method url-fetch)
(uri (string-append "mirror://hackage/package/xmobar/"
"xmobar-" version ".tar.gz"))
(sha256
(base32
- "1xh87asg8y35srvp7d3gyyy4bkxsw122liihxgzgm8pqv2z3h4zd"))))
+ "1sbxva4zaj060bigmxivpn4zlz0q1qbq2np8gljdqkjvysjzpbka"))))
(build-system haskell-build-system)
(native-inputs
`(("ghc-hspec" ,ghc-hspec)
("hspec-discover" ,hspec-discover)))
(inputs
- `(("ghc-hinotify" ,ghc-hinotify)
+ `(("ghc-alsa-core" ,ghc-alsa-core)
+ ("ghc-alsa-mixer" ,ghc-alsa-mixer)
+ ("ghc-dbus" ,ghc-dbus)
+ ("ghc-hinotify" ,ghc-hinotify)
("ghc-http" ,ghc-http)
+ ("ghc-http-conduit" ,ghc-http-conduit)
+ ("ghc-http-types" ,ghc-http-types)
("ghc-iwlib" ,ghc-iwlib)
+ ("ghc-libmpd" ,ghc-libmpd)
+ ("ghc-old-locale" ,ghc-old-locale)
("ghc-parsec-numbers" ,ghc-parsec-numbers)
("ghc-regex-compat" ,ghc-regex-compat)
+ ("ghc-temporary" ,ghc-temporary)
+ ("ghc-timezone-olson" ,ghc-timezone-olson)
+ ("ghc-x11" ,ghc-x11)
("ghc-x11-xft" ,ghc-x11-xft)
("libxpm" ,libxpm)))
(arguments
- `(#:configure-flags
- (list (string-append "--flags="
- (string-join (list "with_inotify"
- "with_iwlib"
- "with_utf8"
- "with_weather"
- "with_xft"
- "with_xpm")
- " ")))))
+ `(#:configure-flags (list "--flags=all_extensions")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-test-shebang
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "test/Xmobar/Plugins/Monitors/AlsaSpec.hs"
+ (("/bin/bash") (which "bash")))
+ #t)))))
(home-page "http://xmobar.org")
(synopsis "Minimalistic text based status bar")
(description