summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorqblade <qblade@protonmail.com>2021-03-07 02:31:07 +0000
committerLudovic Courtès <ludo@gnu.org>2021-03-17 23:10:20 +0100
commit966e61fb8f3ae1313545db7ed9994bc290666ee9 (patch)
treeb445fa83a7f80f6f3b491600e95898465368374b /gnu/packages/wm.scm
parentce10e2b3e93476a89cf85838fa21bb8b54268b1f (diff)
downloadguix-patches-966e61fb8f3ae1313545db7ed9994bc290666ee9.tar
guix-patches-966e61fb8f3ae1313545db7ed9994bc290666ee9.tar.gz
gnu: Add libucl.
* gnu/packages/wm.scm (libucl): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 9c5938bd87..3d85392394 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2371,3 +2372,31 @@ shows a notification for the user on the screen.")
for wayland conceptually based on the X11 window manager
@command{ratpoison}.")
(license license:expat)))
+
+(define-public libucl
+ (package
+ (name "libucl")
+ (version "0.8.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vstakhov/libucl/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h52ldxankyhbbm1qbqz1f2q0j03c1b4mig7343bs3mc6fpm18gf"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("libtool" ,libtool)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ;; no tests
+ (home-page "https://github.com/vstakhov/libucl")
+ (synopsis "Universal configuration language (UCL) parser")
+ (description "libucl implements a configuration language that is easy to
+read and write, and compatible with JSON.")
+ (license license:bsd-2)))