summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-11-29 22:05:44 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-11-29 23:49:22 +0300
commit8ff162332cd06da4303c8eebc685ef5273cc2406 (patch)
treee03de0c9750e9a3722ae7f44d9b49b22c0d214ef /gnu/packages/wm.scm
parent5fb3be0ec40898ab9ede8ffdfc4b05b69815351d (diff)
downloadguix-patches-8ff162332cd06da4303c8eebc685ef5273cc2406.tar
guix-patches-8ff162332cd06da4303c8eebc685ef5273cc2406.tar.gz
gnu: xclickroot: Update to 1.2.
* gnu/packages/wm.scm (xclickroot): Update to 1.2.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm56
1 files changed, 27 insertions, 29 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index b21ac6f046..b13660ba14 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1928,36 +1928,34 @@ wasting your precious memory.")
(license license:x11))))
(define-public xclickroot
- (let ((commit "309fd17174dba4149b5ea66654c6fd02cfcf7c9a")
- (revision "1"))
- (package
- (name "xclickroot")
- (version (git-version "0.0.1" revision commit)) ;no upstream release
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/phillbush/xclickroot")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0fjqkg3wnyks0my1vrzhxfjicsfy8xwnijaazmpz6mhilcqkpvnd"))))
- (build-system gnu-build-system)
- (inputs
- `(("libx11" ,libx11)))
- (arguments
- `(#:tests? #f ;no test suite
- #:make-flags
- (list ,(string-append "CC=" (cc-for-target))
- (string-append "PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
- (home-page "https://github.com/phillbush/xclickroot")
- (synopsis "Run a command when a mouse button is pressed on the root window")
- (description "@code{xclickroot} runs a command every time a given mouse
+ (package
+ (name "xclickroot")
+ (version "1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phillbush/xclickroot")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nd5qz0qz5j7gx2jsbcp234giwaa0xmg42vrcjrcf587q9ivakfl"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libx11" ,libx11)))
+ (arguments
+ `(#:tests? #f ;no test suite
+ #:make-flags
+ (list ,(string-append "CC=" (cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/phillbush/xclickroot")
+ (synopsis "Run a command when a mouse button is pressed on the root window")
+ (description "@code{xclickroot} runs a command every time a given mouse
button is pressed on the root window.")
- (license license:public-domain))))
+ (license license:public-domain)))
(define-public xmenu
(package