summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2020-06-04 17:32:55 -0500
committerOleg Pykhalov <go.wigust@gmail.com>2020-06-09 22:07:52 +0300
commit81b045e149daffd113208601b764fdb47cf6c14b (patch)
treeff9b7f5524b91b0e7ff5ece5c3595a9384bcd856 /gnu/packages/wm.scm
parent152d50d903003e2e88ba6064d09a5ec1a0a7fc34 (diff)
downloadguix-patches-81b045e149daffd113208601b764fdb47cf6c14b.tar
guix-patches-81b045e149daffd113208601b764fdb47cf6c14b.tar.gz
gnu: stumpwm: Update contrib module package names.
This also causes the contribution modules to inherit from a common base. * gnu/packages/wm.scm (stumpish, sbcl-stumpwm-ttf-fonts, sbcl-stumpwm-pass, sbcl-stumpwm-globalwindows, sbcl-stumpwm-swm-gaps): Bring package name in line with the Guix symbol name. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm220
1 files changed, 91 insertions, 129 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 06d28e30c1..daeddc3c0f 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1660,11 +1660,11 @@ productive, customizable lisp based systems.")
(delete 'cleanup)
(delete 'create-symlinks)))))))
-(define-public stumpish
- (let ((commit "920f8fc1488f7953f205e1dda4c2ecbbbda56d6")
+(define stumpwm-contrib
+ (let ((commit "920f8fc1488f7953f205e1dda4c2ecbbbda56d63")
(revision "2"))
(package
- (name "stumpish")
+ (name "stumpwm-contrib")
(version (git-version "0.0.1" revision commit)) ;no upstream release
(source
(origin
@@ -1672,154 +1672,116 @@ productive, customizable lisp based systems.")
(uri (git-reference
(url "https://github.com/stumpwm/stumpwm-contrib.git")
(commit commit)))
- (file-name (git-file-name name version))
(sha256
(base32 "0giac390bq95ag41xkxqp8jjrhfx1wpgglz7jg5rkm0wjhcwmyml"))))
+ (build-system asdf-build-system/sbcl)
(inputs
- `(("bash" ,bash)
- ("rlwrap" ,rlwrap)))
- (build-system trivial-build-system)
- (arguments
- '(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (copy-recursively (assoc-ref %build-inputs "source") ".")
- (chdir "util/stumpish")
- (substitute* "stumpish"
- (("rlwrap") (string-append (assoc-ref %build-inputs "rlwrap")
- "/bin/rlwrap"))
- (("/bin/sh") (string-append (assoc-ref %build-inputs "bash")
- "/bin/bash")))
- (install-file "stumpish" (string-append %output "/bin")))))
+ `(("stumpwm" ,stumpwm "lib")))
(home-page "https://github.com/stumpwm/stumpwm-contrib")
(synopsis "StumpWM interactive shell")
(description "This package provides a StumpWM interactive shell.")
(license (list license:gpl2+ license:gpl3+ license:bsd-2)))))
+(define-public stumpish
+ (package
+ (inherit stumpwm-contrib)
+ (name "stumpish")
+ (inputs
+ `(("bash" ,bash)
+ ("rlwrap" ,rlwrap)))
+ (build-system trivial-build-system)
+ (arguments
+ '(#:modules ((guix build utils))
+ #:tests? #f
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (copy-recursively (assoc-ref %build-inputs "source") ".")
+ (chdir "util/stumpish")
+ (substitute* "stumpish"
+ (("rlwrap") (string-append (assoc-ref %build-inputs "rlwrap")
+ "/bin/rlwrap"))
+ (("/bin/sh") (string-append (assoc-ref %build-inputs "bash")
+ "/bin/bash")))
+ (install-file "stumpish" (string-append %output "/bin")))))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (synopsis "StumpWM interactive shell")
+ (description "This package provides a StumpWM interactive shell.")
+ (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
+
(define-public sbcl-stumpwm+slynk
(deprecated-package "sbcl-stumpwm-with-slynk" stumpwm+slynk))
(define-public sbcl-stumpwm-ttf-fonts
- (let ((commit "920f8fc1488f7953f205e1dda4c2ecbbbda56d6")
- (revision "2"))
- (package
- (name "sbcl-ttf-fonts")
- (version (git-version "0.0.1" revision commit)) ;no upstream release
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stumpwm/stumpwm-contrib.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0giac390bq95ag41xkxqp8jjrhfx1wpgglz7jg5rkm0wjhcwmyml"))))
- (inputs
- `(("stumpwm" ,stumpwm "lib")
- ("clx-truetype" ,sbcl-clx-truetype)))
- (build-system asdf-build-system/sbcl)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _
- (chdir "util/ttf-fonts"))))))
- (home-page "https://github.com/stumpwm/stumpwm-contrib")
- (synopsis "Implementation of TTF font rendering for Lisp")
- (description "This package provides a Lisp implementation of TTF font
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-ttf-fonts")
+ (inputs
+ `(("stumpwm" ,stumpwm "lib")
+ ("clx-truetype" ,sbcl-clx-truetype)))
+ (arguments
+ '(#:asd-system-name "ttf-fonts"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "util/ttf-fonts") #t)))))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (synopsis "Implementation of TTF font rendering for Lisp")
+ (description "This package provides a Lisp implementation of TTF font
rendering.")
- (license (list license:gpl2+ license:gpl3+ license:bsd-2)))))
+ (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
(define-public sbcl-stumpwm-pass
- (let ((commit "920f8fc1488f7953f205e1dda4c2ecbbbda56d6")
- (revision "2"))
- (package
- (name "sbcl-pass")
- (version (git-version "0.0.1" revision commit)) ;no upstream release
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stumpwm/stumpwm-contrib.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0giac390bq95ag41xkxqp8jjrhfx1wpgglz7jg5rkm0wjhcwmyml"))))
- (inputs
- `(("stumpwm" ,stumpwm "lib")))
- (build-system asdf-build-system/sbcl)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _
- (chdir "util/pass"))))))
- (home-page "https://github.com/stumpwm/stumpwm-contrib")
- (synopsis "Integrate @code{pass} wih StumpWM")
- (description "This package provides an interface which integrates
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-pass")
+ (arguments
+ '(#:asd-system-name "pass"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "util/pass") #t)))))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (synopsis "Integrate @code{pass} wih StumpWM")
+ (description "This package provides an interface which integrates
password-store into StumpWM.")
- (license (list license:gpl2+ license:gpl3+ license:bsd-2)))))
+ (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
(define-public sbcl-stumpwm-globalwindows
- (let ((commit "920f8fc1488f7953f205e1dda4c2ecbbbda56d6")
- (revision "2"))
- (package
- (name "sbcl-globalwindows")
- (version (git-version "0.0.1" revision commit)) ;no upstream release
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stumpwm/stumpwm-contrib.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0giac390bq95ag41xkxqp8jjrhfx1wpgglz7jg5rkm0wjhcwmyml"))))
- (inputs
- `(("stumpwm" ,stumpwm "lib")))
- (build-system asdf-build-system/sbcl)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _
- (chdir "util/globalwindows"))))))
- (home-page "https://github.com/stumpwm/stumpwm-contrib")
- (synopsis "Manipulate all windows in the current X session")
- (description "This package provides a StumpWM module to manipulate all
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-globalwindows")
+ (arguments
+ '(#:asd-system-name "globalwindows"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "util/globalwindows") #t)))))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (synopsis "Manipulate all windows in the current X session")
+ (description "This package provides a StumpWM module to manipulate all
windows in the current X session.")
- (license (list license:gpl2+ license:gpl3+ license:bsd-2)))))
+ (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
(define-public sbcl-stumpwm-swm-gaps
- (let ((commit "920f8fc1488f7953f205e1dda4c2ecbbbda56d6")
- (revision "2"))
- (package
- (name "sbcl-swm-gaps")
- (version (git-version "0.0.1" revision commit)) ;no upstream release
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stumpwm/stumpwm-contrib.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0giac390bq95ag41xkxqp8jjrhfx1wpgglz7jg5rkm0wjhcwmyml"))))
- (inputs
- `(("stumpwm" ,stumpwm "lib")))
- (build-system asdf-build-system/sbcl)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _
- (chdir "util/swm-gaps"))))))
- (home-page "https://github.com/stumpwm/stumpwm-contrib")
- (synopsis "Gaps between windows for StumpWM")
- (description "This package provides a StumpWM module which adds gaps
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-swm-gaps")
+ (arguments
+ '(#:asd-system-name "swm-gaps"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "util/swm-gaps") #t)))))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (synopsis "Gaps between windows for StumpWM")
+ (description "This package provides a StumpWM module which adds gaps
between windows.")
- (license (list license:gpl2+ license:gpl3+ license:bsd-2)))))
+ (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
(define-public lemonbar
(let ((commit "35183ab81d2128dbb7b6d8e119cc57846bcefdb4")