summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-12-23 11:24:56 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 23:51:10 +0100
commit782b1224ecb6808a524b9f9702ae5f324f4a5562 (patch)
treeedd43529f6e09377580703c143bc74809d071d5d /gnu/packages/wm.scm
parenta4880a27356f55db5959918ef7982b48e8ecb837 (diff)
downloadguix-patches-782b1224ecb6808a524b9f9702ae5f324f4a5562.tar
guix-patches-782b1224ecb6808a524b9f9702ae5f324f4a5562.tar.gz
gnu: bspwm: Don't use unstable tarball.
* gnu/packages/wm.scm (bspwm)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index b050b05656..fd89df0c16 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -108,14 +108,13 @@ nested include statements).")
(version "0.9.5")
(source
(origin
- (file-name (string-append name "-" version ".tar.gz"))
- (method url-fetch)
- (uri (string-append
- "https://github.com/baskerville/bspwm/archive/"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/baskerville/bspwm.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "10pph8wxqysgk7b2h0svs0nwacn1a4y44jnzzry32pd1ysx92d97"))))
+ (base32 "09h3g1rxxjyw861mk32lj774nmwkx8cwxq4wfgmf4dpbizymvhhr"))))
(build-system gnu-build-system)
(inputs
`(("libxcb" ,libxcb)