summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-09-17 01:25:52 +0200
committerMarius Bakke <marius@gnu.org>2021-09-17 01:25:52 +0200
commit5c3cb22c9b2810669999e044b2de5e9331011a83 (patch)
tree3276e19cc1a0af3cece6ce4f2bfa930901888bb4 /gnu/packages/wm.scm
parentc896287ce5eff968a0b323f3a069653a64b96b4c (diff)
parent2a054d29dcfd4b68ed3914886b637f93ac7a0a72 (diff)
downloadguix-patches-5c3cb22c9b2810669999e044b2de5e9331011a83.tar
guix-patches-5c3cb22c9b2810669999e044b2de5e9331011a83.tar.gz
Merge branch 'master' into core-updates-frozen
Conflicts: gnu/packages/bioinformatics.scm gnu/packages/chez.scm gnu/packages/docbook.scm gnu/packages/ebook.scm gnu/packages/gnome.scm gnu/packages/linux.scm gnu/packages/networking.scm gnu/packages/python-web.scm gnu/packages/python-xyz.scm gnu/packages/tex.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/dune.scm guix/build-system/go.scm guix/build-system/linux-module.scm guix/packages.scm
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm43
1 files changed, 41 insertions, 2 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 66440e5008..1986fbb60c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -384,14 +385,14 @@ from many programming languages.")
(define-public i3lock
(package
(name "i3lock")
- (version "2.11.1")
+ (version "2.13")
(source (origin
(method url-fetch)
(uri (string-append "https://i3wm.org/i3lock/i3lock-"
version ".tar.bz2"))
(sha256
(base32
- "015dn534m7cxjvqdncpvaq9p8b2r4w5hp1yanbdy2abmhbcc7a7j"))))
+ "02szjsaz7rqrdkd0r2nwgwa85c4hwfrcskxw7ryk695kmjcfhzv3"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -411,6 +412,43 @@ from many programming languages.")
Despite the name it should work with any X11 window manager.")
(license license:bsd-3)))
+(define-public i3lock-blur
+ (package
+ (name "i3lock-blur")
+ (version "2.10")
+ (source (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/karulont/i3lock-blur")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bd5nrlga5g1sz1f64gnc3dqy8yfrr4q1ss59krymbpxa1hhf55c"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("automake" ,automake)
+ ("autoconf" ,autoconf)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("mesa" ,mesa)
+ ("libev" ,libev)
+ ("linux-pam" ,linux-pam)
+ ("libxcb" ,libxcb)
+ ("libxkbcommon" ,libxkbcommon)
+ ("xcb-util" ,xcb-util)
+ ("xcb-util-image" ,xcb-util-image)
+ ("xcb-util-xrm" ,xcb-util-xrm)))
+ (home-page "https://github.com/karulont/i3lock-blur")
+ (synopsis "Lightweight screen locker with transparent blurring background")
+ (description
+ "Simple X11 screen locker with transparent blurring background developed
+alongside the i3 project. Despite the name it should work with any X11 window
+manager.")
+ (license license:expat)))
+
(define-public i3blocks
(package
(name "i3blocks")
@@ -641,6 +679,7 @@ Features include:
(inputs
`(("imagemagick" ,imagemagick)
("wmctrl" ,wmctrl)
+ ("i3lock" ,i3lock)
("gawk" ,gawk)))
(home-page "https://github.com/meskarune/i3lock-fancy")
(synopsis "Screen locker with screenshot function")