summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorRobert Smith <robertsmith@posteo.net>2020-12-14 21:47:31 -0800
committerLeo Famulari <leo@famulari.name>2020-12-15 01:13:55 -0500
commit338592020af5409f227953596a1882f2bbae7d08 (patch)
tree37e6280e1ad48d712a3d68a9a60854f03293bafd /gnu/packages/wm.scm
parent1c6789464a95e98a795be84cc8f1811d411712ce (diff)
downloadguix-patches-338592020af5409f227953596a1882f2bbae7d08.tar
guix-patches-338592020af5409f227953596a1882f2bbae7d08.tar.gz
gnu: Add kanshi.
* gnu/packages/wm.scm (kanshi): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 6c4f2c6960..e923a7092a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1609,6 +1609,30 @@ Wlroots based compositors.")
compositors that support the layer-shell protocol.")
(license license:expat))) ; MIT license
+(define-public kanshi
+ (package
+ (name "kanshi")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/kanshi")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nbpgm8qnn7ljsg9vgs35kl8l4rrk542vdcbx8wrn9r909ld3x92"))))
+ (build-system meson-build-system)
+ (inputs `(("wayland" ,wayland)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)))
+ (home-page "https://wayland.emersion.fr/kanshi")
+ (synopsis "Hotswappable output profiles for Wayland")
+ (description "Kanshi allows you to define output profiles that are
+automatically enabled and disabled on hotplug. Kanshi can be used with
+Wayland compositors supporting the wlr-output-management protocol.")
+ (license license:expat))) ; MIT license
+
(define-public stumpwm
(package
(name "stumpwm")