summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2020-12-06 21:40:38 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-12-10 16:38:30 +0200
commit3138e4a75b401ceb2231055c9e4952d000baa12d (patch)
treec4ff93b4a747111b5c1aa7c959ba39c511fb218a /gnu/packages/wm.scm
parent793713dc3f227cf3b3a22bf45f6da682fa9165ed (diff)
downloadguix-patches-3138e4a75b401ceb2231055c9e4952d000baa12d.tar
guix-patches-3138e4a75b401ceb2231055c9e4952d000baa12d.tar.gz
gnu: stumpwm-with-slynk: Fix build error.
* gnu/packages/wm.scm (stumpwm-with-slynk)[arguments]: Provide a writable directory to use as $HOME during building. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 73a83c3411..3569d7f057 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
+;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1680,6 +1681,7 @@ productive, customizable lisp based systems.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(program (string-append out "/bin/stumpwm")))
+ (setenv "HOME" "/tmp")
(build-program program outputs
#:entry-program '((stumpwm:stumpwm) 0)
#:dependencies '("stumpwm" "slynk")