summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2021-01-07 19:22:53 +0800
committer宋文武 <iyzsong@member.fsf.org>2021-01-07 19:25:25 +0800
commit106c663dd82ef4d9c34b326f755919f0bd5b889e (patch)
tree02eabe68678bfa7d80a909ffac29f26d5a0adb6a /gnu/packages/wm.scm
parent5babdbdd4a2a80a81e0b41c5c3b5b8ccd24652ea (diff)
downloadguix-patches-106c663dd82ef4d9c34b326f755919f0bd5b889e.tar
guix-patches-106c663dd82ef4d9c34b326f755919f0bd5b889e.tar.gz
gnu: Add cagebreak.
* gnu/packages/wm.scm (cagebreak): New variable.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 9b178ae98d..e1359c8539 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2279,3 +2279,32 @@ start-up.")
(description "XNotify receives a notification specification in stdin and
shows a notification for the user on the screen.")
(license license:expat)))
+
+(define-public cagebreak
+ (package
+ (name "cagebreak")
+ (version "1.4.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/project-repo/cagebreak")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mnxs1m7jrqdl0asx39nxfzvkp7d4jqpdchi63w2yd1igpj2frb2"))))
+ (build-system meson-build-system)
+ (arguments '(#:configure-flags '("-Dxwayland=true")))
+ (native-inputs
+ `(("pandoc" ,pandoc)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("pango" ,pango)
+ ("wlroots" ,wlroots)))
+ (home-page "https://github.com/project-repo/cagebreak")
+ (synopsis "Tiling wayland compositor inspired by ratpoison")
+ (description
+ "@command{cagebreak} is a slim, keyboard-controlled, tiling compositor
+for wayland conceptually based on the X11 window manager
+@command{ratpoison}.")
+ (license license:expat)))