summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2021-03-02 12:43:28 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-02 09:31:52 +0100
commit0eb64c2c85c2046c54dcb425f2bd8578376fa522 (patch)
tree99dc8fd882a00246456430c848d11f1c3c6670ef /gnu/packages/wm.scm
parent4bc9a1f4e3bd39302b4ceaab8589a2e6ef82c4bd (diff)
downloadguix-patches-0eb64c2c85c2046c54dcb425f2bd8578376fa522.tar
guix-patches-0eb64c2c85c2046c54dcb425f2bd8578376fa522.tar.gz
gnu: dwl: Update to 0.2.
* gnu/packages/wm.scm (dwl): Update to 0.2. [arguments]: Remove the install phase. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index a837e6d20b..e0c4d1db84 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1264,7 +1264,7 @@ project derived from the original Calm Window Manager.")
(define-public dwl
(package
(name "dwl")
- (version "0.1")
+ (version "0.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1273,7 +1273,7 @@ project derived from the original Calm Window Manager.")
(file-name (git-file-name name version))
(sha256
(base32
- "18g2sx8cv54zl5iw5m9lzngrp6ra2pyp7c68qps2ava3brw9m0j2"))))
+ "0r5hsxpckkrq1y7bjfq58rlc5xy45z499rg628q3nh289978ail1"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -1283,12 +1283,7 @@ project derived from the original Calm Window Manager.")
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
- (delete 'configure) ; no configure
- (replace 'install ; no install target
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (install-file "dwl" bin)))))))
+ (delete 'configure)))) ; no configure
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs