summaryrefslogtreecommitdiff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-01-24 09:13:11 +0100
committerRutger Helling <rhelling@mykolab.com>2019-01-24 09:35:59 +0100
commita5466f38c131ea23e09ebc2e9679865c065231e9 (patch)
tree1b0dfbbb1e359d15fa209138993eea1d4a07f2d8 /gnu/packages/wine.scm
parentaf83d59ed5ff6c40c798840aec422c7f578a5d3b (diff)
downloadguix-patches-a5466f38c131ea23e09ebc2e9679865c065231e9.tar
guix-patches-a5466f38c131ea23e09ebc2e9679865c065231e9.tar.gz
gnu: Add wine-minimal.
* gnu/packages/wine.scm (wine-minimal): New variable.
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 42bec5cca5..b5d52170b1 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -66,7 +66,8 @@
#:use-module (gnu packages vulkan)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
- #:use-module (ice-9 match))
+ #:use-module (ice-9 match)
+ #:use-module (srfi srfi-1))
(define-public wine
(package
@@ -224,6 +225,23 @@ integrate Windows applications into your desktop.")
(synopsis "Implementation of the Windows API (WoW64 version)")
(supported-systems '("x86_64-linux" "aarch64-linux"))))
+;; This minimal build of Wine is needed to prevent a circular dependency with
+;; vkd3d.
+(define-public wine-minimal
+ (package
+ (inherit wine)
+ (name "wine-minimal")
+ (native-inputs (fold alist-delete (package-native-inputs wine)
+ '("gettext" "perl" "pkg-config")))
+ (inputs `())
+ (arguments
+ `(#:validate-runpath? #f
+ #:configure-flags
+ (list "--without-freetype"
+ "--without-x")
+ ,@(strip-keyword-arguments '(#:configure-flags)
+ (package-arguments wine))))))
+
(define-public wine-staging-patchset-data
(package
(name "wine-staging-patchset-data")