summaryrefslogtreecommitdiff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-03 15:45:44 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-03 15:45:44 +0100
commit52665d2b6bd709ba46c1e364a6d6164f5f4824ff (patch)
tree55fd79b3939c08f6f6e9fe383f0df5e4caa82b57 /gnu/packages/wine.scm
parent584d08c5c98cb1893e4f44bd1c4191f405b13f01 (diff)
parent0a83339bb1429332ee889e9a976aa214ae2ac0db (diff)
downloadguix-patches-52665d2b6bd709ba46c1e364a6d6164f5f4824ff.tar
guix-patches-52665d2b6bd709ba46c1e364a6d6164f5f4824ff.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm52
1 files changed, 28 insertions, 24 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 0700fdce20..f5b879ae36 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2017 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2017, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;;
@@ -76,15 +76,15 @@
(define-public wine
(package
(name "wine")
- (version "4.0.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://dl.winehq.org/wine/source/"
- (version-major+minor version)
- "/wine-" version ".tar.xz"))
- (sha256
- (base32
- "1nhgw1wm613ln9dhjm0d03zs5adcmnqr2b50p21jbmm5k2gns0i5"))))
+ (version "5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://dl.winehq.org/wine/source/"
+ (version-major+minor version)
+ "/wine-" version ".tar.xz"))
+ (sha256
+ (base32 "1d0kcy338radq07hrnzcpc9lc9j2fvzjh37q673002x8d6x5058q"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("gettext" ,gettext-minimal)
@@ -96,6 +96,7 @@
("dbus" ,dbus)
("cups" ,cups)
("eudev" ,eudev)
+ ("faudio" ,faudio)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
("glu" ,glu)
@@ -322,7 +323,7 @@ integrate Windows applications into your desktop.")
(define-public wine-staging-patchset-data
(package
(name "wine-staging-patchset-data")
- (version "4.18")
+ (version "5.0")
(source
(origin
(method git-fetch)
@@ -331,7 +332,7 @@ integrate Windows applications into your desktop.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "03z0haf47mpm2aj9cji3wma4jy6j12wz10kkbgmbgrkkrc5lcqc2"))))
+ (base32 "054m2glvav29qnlgr3p36kahyv3kbxzba82djzqpc7cmsrin0d3f"))))
(build-system trivial-build-system)
(native-inputs
`(("bash" ,bash)
@@ -368,18 +369,21 @@ integrate Windows applications into your desktop.")
(inherit wine)
(name "wine-staging")
(version (package-version wine-staging-patchset-data))
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://dl.winehq.org/wine/source/"
- (version-major version) ".x"
- "/wine-" version ".tar.xz"))
- (file-name (string-append name "-" version ".tar.xz"))
- (sha256
- (base32
- "0chf6vdy41kg75liibkb862442zwi8dbjzf6l5arcy2z4580a2yi"))))
- (inputs `(("autoconf" ,autoconf) ; for autoreconf
- ("faudio" ,faudio)
+ (source
+ (origin
+ (method url-fetch)
+ (uri (let ((dir (string-append
+ (version-major version)
+ (if (string-suffix? ".0" (version-major+minor version))
+ ".0"
+ ".x"))))
+ (string-append
+ "https://dl.winehq.org/wine/source/" dir
+ "/wine-" version ".tar.xz")))
+ (file-name (string-append name "-" version ".tar.xz"))
+ (sha256
+ (base32 "1d0kcy338radq07hrnzcpc9lc9j2fvzjh37q673002x8d6x5058q"))))
+ (inputs `(("autoconf" ,autoconf) ; for autoreconf
("ffmpeg" ,ffmpeg)
("gtk+" ,gtk+)
("libva" ,libva)