summaryrefslogtreecommitdiff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-11-02 12:01:49 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-11-02 12:01:49 +0100
commit223492f35025215f2ea07f61a75e53b96794e6ed (patch)
tree335ffdec0cb55f63e8246e9cb4e55876e4dbdc37 /gnu/packages/wine.scm
parentab1c063ab08e069fbe62919828fa634a2e222bbf (diff)
downloadguix-patches-223492f35025215f2ea07f61a75e53b96794e6ed.tar
guix-patches-223492f35025215f2ea07f61a75e53b96794e6ed.tar.gz
gnu: dxvk: Fix inputs and configure flag expansion.
* gnu/packages/wine.scm (dxvk)[arguments]: Unquote match. [native-inputs]: Remove wine and dxvk32... [inputs]: ...And add them here.
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index e561d5c79e..d2c0bf0a44 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -585,9 +585,9 @@ Use @command{setup_dxvk} to install the required libraries to a Wine prefix.")
`(#:configure-flags (list "--cross-file"
(string-append (assoc-ref %build-inputs "source")
"/build-wine"
- (match (%current-system)
- ("x86_64-linux" "64")
- (_ "32"))
+ ,(match (%current-system)
+ ("x86_64-linux" "64")
+ (_ "32"))
".txt"))
#:phases
(modify-phases %standard-phases
@@ -616,8 +616,9 @@ Use @command{setup_dxvk} to install the required libraries to a Wine prefix.")
(_ "../lib")))
(("x64") "../lib"))))))))
(native-inputs
- `(("glslang" ,glslang)
- ("wine" ,(match (%current-system)
+ `(("glslang" ,glslang)))
+ (inputs
+ `(("wine" ,(match (%current-system)
("x86_64-linux" wine64)
(_ wine)))
,@(match (%current-system)