summaryrefslogtreecommitdiff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-08-05 21:10:05 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-08-30 17:31:09 +0200
commit07328706313bc52a1ad5842e02bd0c50e5312833 (patch)
treeb4cef2d82711b5c879a1f45b6562b9f9321e1ff2 /gnu/packages/wine.scm
parentb12d856da9a9f088f15a29da87cf4304b5379e5d (diff)
downloadguix-patches-07328706313bc52a1ad5842e02bd0c50e5312833.tar
guix-patches-07328706313bc52a1ad5842e02bd0c50e5312833.tar.gz
gnu: wine: Update to 6.14.
* gnu/packages/wine.scm (wine): Update to 6.14. [#:phases]: Patch Makefile to correctly locate ntdll.so. (wine64)[#:phases]: Likewise.
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm24
1 files changed, 21 insertions, 3 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 5c6d02eec5..fccdc186d2 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -75,7 +75,7 @@
(define-public wine
(package
(name "wine")
- (version "6.8")
+ (version "6.14")
(source
(origin
(method url-fetch)
@@ -87,7 +87,7 @@
(string-append "https://dl.winehq.org/wine/source/" dir
"wine-" version ".tar.xz")))
(sha256
- (base32 "1n7bd6kkhfgi23bz981qml3lajgvbs3ibqrc2mqjhhfqczg2shjv"))))
+ (base32 "00jjqbl0xzsp2swzxgx3a2b16p26qbxvcz82a7ihig23k69p3d34"))))
(build-system gnu-build-system)
(native-inputs
`(("bison" ,bison)
@@ -194,7 +194,16 @@
(substitute* "include/config.h"
(("(#define SONAME_.* )\"(.*)\"" _ defso soname)
(format #f "~a\"~a\"" defso (find-so soname))))
- #t))))))
+ #t)))
+ (add-after 'patch-generated-file-shebangs 'patch-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "make" "Makefile") ; Makefile is first regenerated
+ (substitute* "Makefile"
+ (("-lntdll" id)
+ (string-append id
+ " -Wl,-rpath=" (assoc-ref outputs "out")
+ "/lib/wine32/wine/$(ARCH)-unix")))
+ #t)))))
(home-page "https://www.winehq.org/")
(synopsis "Implementation of the Windows API (32-bit only)")
(description
@@ -254,6 +263,15 @@ integrate Windows applications into your desktop.")
#t)))))
(_
`()))
+ (add-after 'patch-generated-file-shebangs 'patch-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "make" "Makefile") ; Makefile is first regenerated
+ (substitute* "Makefile"
+ (("-lntdll" id)
+ (string-append id
+ " -Wl,-rpath=" (assoc-ref outputs "out")
+ "/lib/wine64/wine/$(ARCH)-unix")))
+ #t))
(add-after 'install 'copy-wine32-binaries
(lambda* (#:key outputs #:allow-other-keys)
(let* ((wine32 (assoc-ref %build-inputs "wine"))