summaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-07 16:34:10 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-07 17:07:16 +0200
commit7f0980839e4d9d3c7e06301bcbb2eb292bd7dbee (patch)
tree4b75779962ef3aa54214c11f37829708401b45eb /gnu/packages/wget.scm
parentc89e21078862bd29b70a3bc0f33d160c59720364 (diff)
downloadguix-patches-7f0980839e4d9d3c7e06301bcbb2eb292bd7dbee.tar
guix-patches-7f0980839e4d9d3c7e06301bcbb2eb292bd7dbee.tar.gz
gnu: wget: Fix compilation with Perl 5.26; skip faulty tests.
* gnu/packages/wget.scm (wget)[arguments]: New field. [source](patches): Add "wget-perl-5.26.patch". * gnu/packages/patches/wget-perl-5.26.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index a73c68004d..58a1a4b885 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -41,11 +41,23 @@
(uri (string-append "mirror://gnu/wget/wget-"
version ".tar.xz"))
(patches (search-patches "wget-CVE-2017-6508.patch"
- "wget-fix-504-test-timeout.patch"))
+ "wget-fix-504-test-timeout.patch"
+ "wget-perl-5.26.patch"))
(sha256
(base32
"1ljcfhbkdsd0zjfm520rbl1ai62fc34i7c45sfj244l8f6b0p58c"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'check 'disable-https-tests
+ (lambda _
+ ;; XXX: Skip TLS tests, which fail with "The
+ ;; certificate's owner does not match hostname" for
+ ;; obscure reasons reported at:
+ ;; <https://lists.gnu.org/archive/html/bug-wget/2017-06/msg00009.html>.
+ (substitute* "testenv/Makefile"
+ (("SSL_TESTS=1") ""))
+ #t)))))
(inputs
`(("gnutls" ,gnutls)
("libidn2" ,libidn2)