summaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-01 03:01:33 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-01 04:44:34 +0200
commit57ea4dfca1212687213a2db8cd47addf85e2ea3f (patch)
tree8d456f0fc3ce8052adb579f25a068529280dfbc8 /gnu/packages/wget.scm
parente071b0c940c20bb79bca3281003836eaf5ed7a0e (diff)
downloadguix-patches-57ea4dfca1212687213a2db8cd47addf85e2ea3f.tar
guix-patches-57ea4dfca1212687213a2db8cd47addf85e2ea3f.tar.gz
gnu: wgetpaste: Fix historical confusion.
* gnu/packages/wget.scm (wgetpaste)[arguments]: Fix the reversed substitution and clarify its purpose.
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index d7ac9e0c12..0c6d27471b 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -94,12 +94,12 @@ in downloaded documents to relative links.")
(modify-phases %standard-phases
(delete 'configure)
(delete 'build)
- (add-after 'unpack 'remove-dead-paste-site
- ;; This phase is adaped from the following patch:
- ;; https://gitweb.gentoo.org/repo/gentoo.git/tree/app-text/wgetpaste/files/wgetpaste-remove-dead.patch
+ (add-after 'unpack 'change-unfriendly-default
(lambda _
(substitute* "wgetpaste"
- (("-bpaste") "-dpaste")) ; dpaste blocks tor users
+ ;; dpaste blocks Tor users. Use a better default.
+ (("DEFAULT_SERVICE:-dpaste")
+ "DEFAULT_SERVICE-bpaste"))
#t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)