summaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-30 01:51:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-30 03:46:21 +0200
commit56e59b3993fd4de99ecf43acbf661d0db339f6b2 (patch)
tree2977a21eb6d5bee6fda577b083ad992eb6fe665e /gnu/packages/wget.scm
parent0f6dc120cadfe94110467072d5c6f23357173b95 (diff)
downloadguix-patches-56e59b3993fd4de99ecf43acbf661d0db339f6b2.tar
guix-patches-56e59b3993fd4de99ecf43acbf661d0db339f6b2.tar.gz
gnu: wget2: Return #t from phases.
* gnu/packages/wget.scm (wget2)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index bd43e372cf..0fb1142b68 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -149,9 +150,9 @@ online pastebin services.")
(find-files "."))
(substitute* "./gnulib/gnulib-tool.py"
(("/usr/bin/python") (which "python3")))
- (zero? (system* "sh" "./bootstrap"
+ (invoke "sh" "./bootstrap"
"--gnulib-srcdir=gnulib"
- "--no-git")))))))
+ "--no-git"))))))
(inputs `(("autoconf" ,autoconf)
("automake" ,automake)
("doxygen" ,doxygen)