summaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-08 16:39:45 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-08 16:39:45 +0200
commit3512bd4d1ca5946cda44854bf0d526c6c288ad4c (patch)
tree3e4c904e1d3a52ec11f815c22fa74958c0b33eed /gnu/packages/wget.scm
parent2deb146f6d2f38aa121c51b3141c33790a734be5 (diff)
downloadguix-patches-3512bd4d1ca5946cda44854bf0d526c6c288ad4c.tar
guix-patches-3512bd4d1ca5946cda44854bf0d526c6c288ad4c.tar.gz
gnu: wget: Update comment about test failures.
* gnu/packages/wget.scm (wget)[arguments]: Update comment.
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 58a1a4b885..3673ad5cc4 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -52,9 +52,13 @@
(add-before 'check 'disable-https-tests
(lambda _
;; XXX: Skip TLS tests, which fail with "The
- ;; certificate's owner does not match hostname" for
- ;; obscure reasons reported at:
- ;; <https://lists.gnu.org/archive/html/bug-wget/2017-06/msg00009.html>.
+ ;; certificate's owner does not match hostname" as
+ ;; reported at:
+ ;; <https://lists.gnu.org/archive/html/bug-wget/2017-07/msg00012.html>.
+ ;; The problem appears to be due to a change in GnuTLS
+ ;; 3.5.12, whereby 'gnutls_x509_crt_check_hostname2' no
+ ;; longer matches IP address against the 'CN' or
+ ;; 'DNSname' fields of certificates.
(substitute* "testenv/Makefile"
(("SSL_TESTS=1") ""))
#t)))))