summaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-05-23 20:58:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-05-23 20:58:47 +0300
commit234999497d1ab0ec0efa945e33378e3ca4ebf92e (patch)
treea927d897a147e7f677d9a70df8af352dede139c3 /gnu/packages/wget.scm
parente4ff9dffe7cc0902dba87f2ce1d5cb884cf33785 (diff)
downloadguix-patches-234999497d1ab0ec0efa945e33378e3ca4ebf92e.tar
guix-patches-234999497d1ab0ec0efa945e33378e3ca4ebf92e.tar.gz
gnu: wgetpaste: Remove dead paste site.
* gnu/packages/wget.scm (wgetpaste)[arguments]: Add custom phase to remove newly defunct paste site.
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 93a40c487a..4940156db5 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -96,6 +96,14 @@ in downloaded documents to relative links.")
(modify-phases %standard-phases
(delete 'configure)
(delete 'build)
+ (add-after 'unpack 'remove-dead-paste-site
+ ;; This phase is adaped from the following patch:
+ ;; https://gitweb.gentoo.org/repo/gentoo.git/tree/app-text/wgetpaste/files/wgetpaste-remove-dead.patch
+ (lambda _
+ (substitute* "wgetpaste"
+ ((" poundpython\"") "\"")
+ (("-poundpython") "-dpaste"))
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))