summaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-21 22:10:11 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-29 09:35:39 +0200
commit22486fbea669c5e1a5e19b52fc37c44f6f615de5 (patch)
tree3759535e90cfd9112a1d05e4c2d6915c12710948 /gnu/packages/wget.scm
parent3e757c005f91182c69c9a08f0cfa8a3c75ba7c6e (diff)
downloadguix-patches-22486fbea669c5e1a5e19b52fc37c44f6f615de5.tar
guix-patches-22486fbea669c5e1a5e19b52fc37c44f6f615de5.tar.gz
gnu: Add wgetpaste.
* gnu/packages/wget.scm (wgetpaste): New variable.
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 80da33272e..72aab86c14 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,3 +61,36 @@ HTTPS and FTP protocols. It can resume interrupted downloads, use file name
wild cards, supports proxies and cookies, and it can convert absolute links
in downloaded documents to relative links.")
(license gpl3+))) ; some files are under GPLv2+
+
+(define-public wgetpaste
+ (package
+ (name "wgetpaste")
+ (version "2.28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://wgetpaste.zlin.dk/wgetpaste-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1hh9svyypqcvdg5mjxyyfzpdzhylhf7s7xq5dzglnm4injx3i3ak"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (zsh (string-append out "/share/zsh/site-functions")))
+ (install-file "wgetpaste" bin)
+ (install-file "_wgetpaste" zsh)))))
+ #:tests? #f)) ; no test target
+ (home-page "http://wgetpaste.zlin.dk/")
+ (synopsis "Script that automates pasting to a number of pastebin services")
+ (description
+ "@code{wgetpaste} is an extremely simple command-line interface to various
+online pastebin services.")
+ (license public-domain)))