summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-11 14:21:22 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-11 19:48:32 +0100
commitf85ca6eda044c43bd5b9b54e756c02fd90c372f1 (patch)
tree805492e5cdf53a5f10db6e359133868c65cd9926 /gnu/packages/webkit.scm
parent66679ab97846568a8a222afddc5181586636b74e (diff)
downloadguix-patches-f85ca6eda044c43bd5b9b54e756c02fd90c372f1.tar
guix-patches-f85ca6eda044c43bd5b9b54e756c02fd90c372f1.tar.gz
gnu: Remove WebKitGTK@2.20.
* gnu/packages/gnome.scm (eolie, epiphany)[native-inputs]: Remove GCC-7. [inputs]: Change WEBKITGTK-2.22 to WEBKITGTK. [arguments]: Adjust accordingly. * gnu/packages/web-browsers.scm (next-gtk-webkit): Likewise. * gnu/packages/webkit.scm (webkitgtk): Update to 2.22.6. (webkitgtk-2.22): Remove variable.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm34
1 files changed, 2 insertions, 32 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 91c6c7d02a..af34052ee4 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -59,14 +59,14 @@
(define-public webkitgtk
(package
(name "webkitgtk")
- (version "2.20.5")
+ (version "2.22.6")
(source (origin
(method url-fetch)
(uri (string-append "https://www.webkitgtk.org/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
- "147r7an41920zl4x9srdva7fxvw2znjin5ldjkhay1cndv9gih0m"))))
+ "0ny8azipr2dmdk79qrf4hvb2p4k5b3af38szjhmhg8mh1nfdp46z"))))
(build-system cmake-build-system)
(outputs '("out" "doc"))
(arguments
@@ -160,33 +160,3 @@ HTML/CSS applications to full-fledged web browsers.")
license:lgpl2.1+
license:bsd-2
license:bsd-3))))
-
-;; This version of webkitgtk needs to be kept separate, because it requires a
-;; newer version of GCC than our default compiler, and this causes problems
-;; when linked with C++ libraries built using our default compiler. For now,
-;; we use this newer webkitgtk only for selected packages, e.g. epiphany.
-(define-public webkitgtk-2.22
- (package/inherit webkitgtk
- (name "webkitgtk")
- (version "2.22.6")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://www.webkitgtk.org/releases/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "0ny8azipr2dmdk79qrf4hvb2p4k5b3af38szjhmhg8mh1nfdp46z"))))
- (native-inputs
- `(("gcc" ,gcc-7) ; webkitgtk-2.22 requires gcc-6 or newer
- ,@(package-native-inputs webkitgtk)))
- (arguments
- (substitute-keyword-arguments (package-arguments webkitgtk)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-before 'configure 'work-around-gcc-7-include-path-issue
- ;; FIXME: Work around a problem with gcc-7 includes (see
- ;; <https://bugs.gnu.org/30756>).
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t))))))))