summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-05-29 15:50:14 +0800
committer宋文武 <iyzsong@gmail.com>2015-05-29 16:05:49 +0800
commite7e8ea069e52052ab35a57284e18d171ab0f2daa (patch)
treee80f6b98cb79af64a35eb5e7e79bf0e2ff2c4406 /gnu/packages/webkit.scm
parenta54bd6d72dc91f649fb2b6cb3c612da1639d9b72 (diff)
downloadguix-patches-e7e8ea069e52052ab35a57284e18d171ab0f2daa.tar
guix-patches-e7e8ea069e52052ab35a57284e18d171ab0f2daa.tar.gz
gnu: webkitgtk-2.4: Update to 2.8.9, build with gtk3.
* gnu/packages/webkit.scm (webkitgtk-2.4): Update to 2.8.9, build with gtk3. Move flex and which to 'native-inputs'. Remove #:configure-flags. (webkitgtk/gtk+-2): New variable. * gnu/packages/gnucash.scm (gnucash): Use webkitgtk/gtk+-2. * gnu/packages/patches/webkitgtk-2.4.8-gmutexlocker.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove it. Co-authored-by: Feng Shu <tumashu@163.com>
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm28
1 files changed, 19 insertions, 9 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index b091c88601..d2a7f059c3 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -114,29 +114,39 @@ HTML/CSS applications to full-fledged web browsers.")
license:bsd-2
license:bsd-3))))
+;; Latest release of the stable 2.4 series, with WebKit1 support.
(define-public webkitgtk-2.4
- ;; Latest release of the stable 2.4 series.
(package (inherit webkitgtk)
(name "webkitgtk")
- (version "2.4.8")
+ (version "2.4.9")
(source (origin
(method url-fetch)
(uri (string-append "http://www.webkitgtk.org/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
- "08xxqsxpa63nzgbsz63vrdxdxgpysyiy7jdcjb57k1hprdcibwb8"))
- (patches (list (search-patch "webkitgtk-2.4.8-gmutexlocker.patch")))))
+ "0r651ar3p0f8zwl7764kyimxk5hy88cwy116pv8cl5l8hbkjkpxg"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no tests
#:phases (modify-phases %standard-phases
(add-after
'unpack 'set-gcc
- (lambda _ (setenv "CC" "gcc") #t)))
- #:configure-flags '("--enable-webkit2=no"
- "--with-gtk=2.0")))
- (inputs
+ (lambda _ (setenv "CC" "gcc") #t)))))
+ (native-inputs
`(("flex" ,flex)
("which" ,which)
- ,@(package-inputs webkitgtk)))))
+ ,@(package-native-inputs webkitgtk)))))
+
+;; Last GTK+2 port, required by GnuCash.
+(define-public webkitgtk/gtk+-2
+ (package (inherit webkitgtk-2.4)
+ (name "webkitgtk")
+ (arguments
+ `(#:configure-flags
+ '("--enable-webkit2=no"
+ "--with-gtk=2.0")
+ ,@(package-arguments webkitgtk-2.4)))
+ (propagated-inputs
+ `(("gtk+-2" ,gtk+-2)
+ ("libsoup" ,libsoup)))))