summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-06 23:37:40 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-06 23:37:40 +0200
commitc263cfdcde0402cf44be7b14841d567f00e0af11 (patch)
tree311052b6ad6e391571f4e45631f5c3ca991b0cda /gnu/packages/webkit.scm
parent3b7f3108e0ebd459ec9c75717988fc61755e7185 (diff)
parent13c18af1d835db11f3f4cf34e65c7da706625a3f (diff)
downloadguix-patches-c263cfdcde0402cf44be7b14841d567f00e0af11.tar
guix-patches-c263cfdcde0402cf44be7b14841d567f00e0af11.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index a5e73c2c38..90be7d2625 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -128,7 +128,8 @@ engine that uses Wayland for graphics output.")
"webkitgtk-" version ".tar.xz"))
(sha256
(base32
- "1g9hik3bprki5s9d7y5288q5irwckbzajr6rnlvjrlnqrwjkblmr"))))
+ "1g9hik3bprki5s9d7y5288q5irwckbzajr6rnlvjrlnqrwjkblmr"))
+ (patches (search-patches "webkitgtk-share-store.patch"))))
(build-system cmake-build-system)
(outputs '("out" "doc"))
(arguments
@@ -156,6 +157,15 @@ engine that uses Wayland for graphics output.")
"-DUSE_WOFF2=OFF")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'configure-bubblewrap-store-directory
+ (lambda _
+ ;; This phase is a corollary to 'webkitgtk-share-store.patch' to
+ ;; avoid hard coding /gnu/store, for users with other prefixes.
+ (let ((store-directory (%store-directory)))
+ (substitute*
+ "Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp"
+ (("@storedir@") store-directory))
+ #t)))
(add-after 'unpack 'patch-gtk-doc-scan
(lambda* (#:key inputs #:allow-other-keys)
(for-each (lambda (file)