summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-08-15 01:03:53 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-08-16 16:07:47 -0400
commitbc549a276cd9c10202427d220d87f50eb3784d42 (patch)
tree50178a051dfbd95a430440443adee23e1b27b08c /gnu/packages/webkit.scm
parentd7d362b7dd2542db105621578656d9fad134953e (diff)
downloadguix-patches-bc549a276cd9c10202427d220d87f50eb3784d42.tar
guix-patches-bc549a276cd9c10202427d220d87f50eb3784d42.tar.gz
gnu: webkitgtk: Expose all font locations to the bubblewrap sandbox.
Fixes <https://issues.guix.gnu.org/41174> and <https://issues.guix.gnu.org/42618>. The webkitgtk library relied on by Epiphany and others uses bubblewrap to sandbox its process. This sandbox was only exposing fonts relative to XDG_DATA_HOME. Extend it so that it honors font locations specified via XDG_DATA_DIRS as well, which is what Guix uses. * gnu/packages/patches/webkitgtk-bind-all-fonts.patch: Add patch. * gnu/local.mk: Register it. * gnu/packages/webkit.scm (webkitgtk)[source]<patches>: Use it. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 5a517c3b87..80df8560d9 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -129,7 +129,8 @@ engine that uses Wayland for graphics output.")
(sha256
(base32
"0r4lkk21pny2g4mmsw0ds14m5hhjys1l47gvy59dfgihr7l546c2"))
- (patches (search-patches "webkitgtk-share-store.patch"))))
+ (patches (search-patches "webkitgtk-share-store.patch"
+ "webkitgtk-bind-all-fonts.patch"))))
(build-system cmake-build-system)
(outputs '("out" "doc"))
(arguments