summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-02-06 23:26:24 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-02-24 09:22:54 -0500
commitb9a4705f80e89fff3b65288cbbe8df73a365aee3 (patch)
treec5a84b910034203d8ec257701bcefd0b2c163a00 /gnu/packages/webkit.scm
parent57d0b1afb25881b2fa94e541d0ca586595cca8b9 (diff)
downloadguix-patches-b9a4705f80e89fff3b65288cbbe8df73a365aee3.tar
guix-patches-b9a4705f80e89fff3b65288cbbe8df73a365aee3.tar.gz
gnu: webkitgtk: Adjust BubbleWrap wrapper.
This revisits <https://issues.guix.gnu.org/40837> with a fix that doesn't require to have PULSE_CLIENTCONFIG point to an absolute store location, which will allow us to revert to have PULSE_CLIENTCONFIG point to a fixed location under /etc. This would alleviate the need to reboot to have changes to the PulseAudio configuration effected. * gnu/packages/patches/webkitgtk-share-store.patch: Delete file. * gnu/packages/patches/webkitgtk-bubblewrap-paths.patch: Add file. * gnu/packages/patches/webkitgtk-canonicalize-paths.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Update patches list. * gnu/packages/webkit.scm (webkitgtk)[patches]: Adjust accordingly.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 40537f5e0a..f79d6bd4f6 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -247,8 +247,9 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
(sha256
(base32
"1xn1hhd0qaxmjf6vy6664i4mmmjsw9zgrr4w8ni3415d981zvj3b"))
- (patches (search-patches "webkitgtk-share-store.patch"
- "webkitgtk-bind-all-fonts.patch"))))
+ (patches (search-patches "webkitgtk-bind-all-fonts.patch"
+ "webkitgtk-adjust-bubblewrap-paths.patch"
+ "webkitgtk-canonicalize-paths.patch"))))
(build-system cmake-build-system)
(outputs '("out" "doc" "debug"))
(arguments