summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-09-26 16:38:20 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-09-27 18:57:37 +0200
commitb037ea963fae0c38f097e857aa5407b1d9f2782d (patch)
treea6346e2b526b42ee051d4e627cc4f56d3848de65 /gnu/packages/webkit.scm
parent36cc160e721a764c16f53c6f7fbd9d09c581717e (diff)
downloadguix-patches-b037ea963fae0c38f097e857aa5407b1d9f2782d.tar
guix-patches-b037ea963fae0c38f097e857aa5407b1d9f2782d.tar.gz
gnu: Add libwpe.
* gnu/packages/webkit.scm (libwpe): New public variable.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 2eca5147fe..e4e7c068e7 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,8 +55,38 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages video)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg))
+(define-public libwpe
+ (package
+ (name "libwpe")
+ (version "1.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://wpewebkit.org/releases/libwpe-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1221vs72zs87anrzhbm6pf8jnii7s6ms7mkzj6nlds9zqd7lklz2"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;no tests
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("mesa" ,mesa)))
+ (propagated-inputs
+ `(;; In Requires of wpe-1.0.pc.
+ ("libxkbcommon" ,libxkbcommon)))
+ (home-page "https://wpewebkit.org/")
+ (synopsis "Platform agnostic WebKit interfaces")
+ (description
+ "@code{libwpe} is a small library that defines programming interfaces
+for use by WebKit, and provides a mechanism for loading a platform-specific
+backend which implements them.")
+ (license license:bsd-2)))
+
(define-public webkitgtk
(package
(name "webkitgtk")