summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-11 18:09:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-11 22:47:06 +0100
commita509b180870cf7bffe65a1cd6099487469fae39f (patch)
tree4eaf06670aaa6a638c7f8556e1b5388a41ea7ff5 /gnu/packages/webkit.scm
parentaaf0e47f6dbe4245ef5d38f69e0e4eb2855de15b (diff)
downloadguix-patches-a509b180870cf7bffe65a1cd6099487469fae39f.tar
guix-patches-a509b180870cf7bffe65a1cd6099487469fae39f.tar.gz
gnu: webkitgtk@2.22: Adjust to documentation output.
This is a follow-up to commit 0ead0b4d2c025ad1b4a293fb6cbb8a578b7dd87d. * gnu/packages/webkit.scm (webkitgtk)[arguments]: Remove hard coded file list. (webkitgtk-2.22)[arguments]: Inherit phases using SUBSTITUTE-KEYWORD-ARGUMENTS.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index dfff53c627..82f03c7f94 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -96,14 +96,12 @@
(modify-phases %standard-phases
(add-after 'unpack 'patch-gtk-doc-scan
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "Source/WebKit/WebProcess/InjectedBundle/API/gtk/DOM/docs/webkitdomgtk-docs.sgml"
- (("http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd")
- (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/docbookx.dtd")))
- (substitute* "Source/WebKit/UIProcess/API/gtk/docs/webkit2gtk-docs.sgml"
- (("http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd")
- (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/docbookx.dtd")))
+ (for-each (lambda (file)
+ (substitute* file
+ (("http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/docbookx.dtd"))))
+ (find-files "Source" "\\.sgml$"))
#t))
(add-after 'install 'move-doc-files
(lambda* (#:key outputs #:allow-other-keys)
@@ -182,12 +180,13 @@ HTML/CSS applications to full-fledged web browsers.")
`(("gcc" ,gcc-7) ; webkitgtk-2.22 requires gcc-6 or newer
,@(package-native-inputs webkitgtk)))
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'configure 'work-around-gcc-7-include-path-issue
- ;; FIXME: Work around a problem with gcc-7 includes (see
- ;; <https://bugs.gnu.org/30756>).
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t)))
- ,@(package-arguments webkitgtk)))))
+ (substitute-keyword-arguments (package-arguments webkitgtk)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'configure 'work-around-gcc-7-include-path-issue
+ ;; FIXME: Work around a problem with gcc-7 includes (see
+ ;; <https://bugs.gnu.org/30756>).
+ (lambda _
+ (unsetenv "C_INCLUDE_PATH")
+ (unsetenv "CPLUS_INCLUDE_PATH")
+ #t))))))))