summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-20 16:56:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-26 00:33:01 +0200
commita0c9ba1d64be641192a22de3284aee2acb69214e (patch)
treeb58ddaeb8d8b7e80ddf231d7dc29949c6962a163 /gnu/packages/webkit.scm
parent9b1bb75781118b1460563171aae503aa9ba702a8 (diff)
downloadguix-patches-a0c9ba1d64be641192a22de3284aee2acb69214e.tar
guix-patches-a0c9ba1d64be641192a22de3284aee2acb69214e.tar.gz
gnu: webkitgtk: Remove obsolete phase.
* gnu/packages/webkit.scm (webkitgtk)[arguments]: Remove #:phases. (webkitgtk-2.22)[arguments]: Don't reference removed phase.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm38
1 files changed, 10 insertions, 28 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 976411dbbc..c5238a8a65 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -87,23 +87,7 @@
;; XXX Disable WOFF2 ‘web fonts’. These were never
;; supported in our previous builds. Enabling them
;; requires building libwoff2 and possibly woff2dec.
- "-DUSE_WOFF2=OFF")
- #:phases
- (modify-phases %standard-phases
- (add-after
- 'set-paths 'add-gst-plugins-base-include-path
- (lambda* (#:key inputs #:allow-other-keys)
- ;; XXX Work around a problem in the build system, which neglects
- ;; to add -I for gst-plugins-base when compiling
- ;; Source/WebKit2/UIProcess/WebPageProxy.cpp, apparently assuming
- ;; that it will be in the same directory as gstreamer's header
- ;; files.
- (setenv "CPATH"
- (string-append (getenv "C_INCLUDE_PATH")
- ":"
- (assoc-ref inputs "gst-plugins-base")
- "/include/gstreamer-1.0"))
- #t)))))
+ "-DUSE_WOFF2=OFF")))
(native-inputs
`(("bison" ,bison)
("gettext" ,gettext-minimal)
@@ -171,14 +155,12 @@ HTML/CSS applications to full-fledged web browsers.")
`(("gcc" ,gcc-7) ; webkitgtk-2.22 requires gcc-6 or newer
,@(package-native-inputs webkitgtk)))
(arguments
- (substitute-keyword-arguments (package-arguments webkitgtk)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'add-gst-plugins-base-include-path
- 'work-around-gcc-7-include-path-issue
- ;; FIXME: Work around a problem with gcc-7 includes (see
- ;; <https://bugs.gnu.org/30756>).
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t))))))))
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'work-around-gcc-7-include-path-issue
+ ;; FIXME: Work around a problem with gcc-7 includes (see
+ ;; <https://bugs.gnu.org/30756>).
+ (lambda _
+ (unsetenv "C_INCLUDE_PATH")
+ (unsetenv "CPLUS_INCLUDE_PATH")
+ #t)))
+ ,@(package-arguments webkitgtk)))))