summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2021-11-20 14:03:08 -0500
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-21 16:43:12 +0100
commit85de88f1adcf5b91afe76bf671c05b8596821920 (patch)
tree4402f12ebee0bc4e91c15e5bea9a3aa7ac3c32cd /gnu/packages/webkit.scm
parent01ea70a29c5c1ded31c37ce8c43192bc1956b2ca (diff)
downloadguix-patches-85de88f1adcf5b91afe76bf671c05b8596821920.tar
guix-patches-85de88f1adcf5b91afe76bf671c05b8596821920.tar.gz
gnu: emacs-xwidgets{,-next-pgtk}: Use webkitgtk-with-libsoup2.
* gnu/packages/emacs.scm (emacs-xwidgets, emacs-next-pgtk)[inputs]: Replace webkitgtk with webkitgtk-with-libsoup2. * gnu/packages/webkit.scm (webkitgtk-with-libsoup2): Add further information about where this package is used and upstream tracker for libsoup3.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 5230129158..f988bf0697 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -364,6 +364,9 @@ HTML/CSS applications to full-fledged web browsers.")
;;; Required by gnome-online-accounts; as webkitgtk 2.34 propagates libsoup 3,
;;; which causes the build to fail.
+;;; Also required by e.g. emacs-next-pgtk, emacs-xwidgets, and some other
+;;; Gnome packages for webkit2gtk-4.0. See also the upstream tracker for
+;;; libsoup 3: https://gitlab.gnome.org/GNOME/libsoup/-/issues/218
(define-public webkitgtk-with-libsoup2
(package/inherit webkitgtk
(name "webkitgtk-with-libsoup2")