summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-19 16:54:10 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-21 17:25:54 +0200
commit8308f0ba9e65daeadcc7e8922377b3d5e9f10e05 (patch)
tree14f657223ff51e717f5152aa22de0389c33b231d /gnu/packages/webkit.scm
parentb1d81ba04368f17ba6d03d3e455c3d885590bb52 (diff)
downloadguix-patches-8308f0ba9e65daeadcc7e8922377b3d5e9f10e05.tar
guix-patches-8308f0ba9e65daeadcc7e8922377b3d5e9f10e05.tar.gz
gnu: webkitgtk: Update to 2.24.2 [security fixes].
This fixes CVE-2019-8595, CVE-2019-8607, and CVE-2019-8615. * gnu/packages/patches/webkitgtk-sse2.patch: Delete file. * gnu/packages/patches/webkitgtk-sans-gstreamer-gl.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/webkit.scm (webkitgtk-2.24): Update to 2.24.2. [source](patches): Add the new patch; remove 'webkitgtk-sse2.patch'.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index ce69d0a7d4..e9b7ab74a7 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -168,15 +168,15 @@ HTML/CSS applications to full-fledged web browsers.")
(define-public webkitgtk-2.24
(package/inherit webkitgtk
(name "webkitgtk")
- (version "2.24.1")
+ (version "2.24.2")
(source (origin
(method url-fetch)
(uri (string-append "https://www.webkitgtk.org/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
- "0v9riwrmwi9wxbb8hlvcbyyxa9zxhcdk6s1xcspalk6asam8xjsk"))
- (patches (search-patches "webkitgtk-sse2.patch"))))
+ "071jnjvjq6wsxx1jh4ql3j53h1nhphs5ga67fa5i9xjvs3qb3701"))
+ (patches (search-patches "webkitgtk-sans-gstreamer-gl.patch"))))
(native-inputs
`(("gcc" ,gcc-7) ; webkitgtk-2.22 requires gcc-6 or newer
,@(package-native-inputs webkitgtk)))