summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-06 19:51:06 -0500
committerMark H Weaver <mhw@netris.org>2018-01-07 01:14:49 -0500
commit56804398a94bea941183ae4ed29d2a9f82069a6f (patch)
treed9439d4ee0024958c22143c8666f857ca6df781b /gnu/packages/webkit.scm
parentc23243fccd4f73430ca06a862acd33c020c8ed17 (diff)
downloadguix-patches-56804398a94bea941183ae4ed29d2a9f82069a6f.tar
guix-patches-56804398a94bea941183ae4ed29d2a9f82069a6f.tar.gz
gnu: webkitgtk: Disable SharedArrayBuffers to mitigate Spectre.
* gnu/packages/patches/webkitgtk-mitigate-spectre.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/webkit.scm (webkitgtk)[source]: Add patch.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index e2d753aa3d..7acc018632 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -61,7 +61,8 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "1f1j0r996l20cgkvbwpizn7d4yp58cy334b1pvn4kfb5c2dbpdl7"))))
+ "1f1j0r996l20cgkvbwpizn7d4yp58cy334b1pvn4kfb5c2dbpdl7"))
+ (patches (search-patches "webkitgtk-mitigate-spectre.patch"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no tests