summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2021-11-05 15:31:34 -0400
committerMark H Weaver <mhw@netris.org>2021-11-06 00:40:54 -0400
commit4fd12fb00d595b6f6a5d5cc734863f4c4bc5f46c (patch)
tree6b9dc116587dca8083872c582025796531ac2da1 /gnu/packages/webkit.scm
parentc55a64cb7e82e88e26c26995f983fc9675b6276e (diff)
downloadguix-patches-4fd12fb00d595b6f6a5d5cc734863f4c4bc5f46c.tar
guix-patches-4fd12fb00d595b6f6a5d5cc734863f4c4bc5f46c.tar.gz
gnu: webkitgtk: Fix build on i686-linux.
Fixes <https://bugs.gnu.org/51591>. * gnu/packages/webkit.scm (webkitgtk)[arguments]: Use quasiquote for the argument list. When building on i686-linux, insert a 'substitute*' form in the 'prepare-build-environment' phase that disables the use of '__builtin_mul_overflow'.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index e54b680855..a184cc9b32 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -241,7 +241,7 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
(build-system cmake-build-system)
(outputs '("out" "doc"))
(arguments
- '(#:tests? #f ; no tests
+ `(#:tests? #f ; no tests
#:build-type "Release" ; turn off debugging symbols to save space
#:configure-flags (list
"-DPORT=GTK"
@@ -299,6 +299,13 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CC" "clang")
(setenv "CXX" "clang++")
+ ;; XXX Until we switch back to using GCC,
+ ;; work around <https://bugs.gnu.org/51591>.
+ ,@(if (string=? "i686-linux" (%current-system))
+ '((substitute* "Source/WTF/wtf/CheckedArithmetic.h"
+ (("#define USE_MUL_OVERFLOW 1")
+ "#define USE_MUL_OVERFLOW 0")))
+ '())
#t))
(add-after 'install 'move-doc-files
(lambda* (#:key outputs #:allow-other-keys)