summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorJakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>2019-07-17 14:11:16 -0400
committerLudovic Courtès <ludo@gnu.org>2019-07-18 15:36:58 +0200
commitf33ee234e57f3398c4fc468e7a5011ff7224a032 (patch)
tree79e269552475f911da501ebdbe99fe2157e51854 /gnu/packages/web.scm
parent330a6ff4ebf32625c34a5e337878482f02abfd96 (diff)
downloadguix-patches-f33ee234e57f3398c4fc468e7a5011ff7224a032.tar
guix-patches-f33ee234e57f3398c4fc468e7a5011ff7224a032.tar.gz
gnu: Add websocketpp.
* gnu/packages/web.scm (websocketpp): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d1f5ec2eb6..f1083505ee 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -71,6 +72,7 @@
#:use-module (gnu packages admin)
#:use-module (gnu packages adns)
#:use-module (gnu packages apr)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages documentation)
#:use-module (gnu packages docbook)
@@ -854,6 +856,39 @@ for efficient socket-like bidirectional reliable communication channels.")
;; This is LGPLv2.1-only with extra exceptions specified in 'LICENSE'.
(license license:lgpl2.1)))
+(define-public websocketpp
+ (package
+ (name "websocketpp")
+ (version "0.8.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zaphoyd/websocketpp.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12ffczcrryh74c1xssww35ic6yiy2l2xgdd30lshiq9wnzl2brgy"))))
+ (build-system cmake-build-system)
+ (inputs `(("boost" ,boost)
+ ("openssl" ,openssl)))
+ (arguments '(#:configure-flags '("-DBUILD_TESTS=ON")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'remove-tests
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((install-dir (assoc-ref outputs "out"))
+ (bin-dir (string-append install-dir "/bin")))
+ (delete-file-recursively bin-dir)
+ #t))))))
+ (home-page "https://www.zaphoyd.com/websocketpp/")
+ (synopsis "C++ library implementing the WebSocket protocol")
+ (description "WebSocket++ is a C++ library that can be used to implement
+WebSocket functionality. The goals of the project are to provide a WebSocket
+implementation that is simple, portable, flexible, lightweight, low level, and
+high performance.")
+ (license license:bsd-3)))
+
(define-public libpsl
(package
(name "libpsl")