summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-01 05:30:55 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-01 05:30:55 +0100
commitd85edd7a9528fc9f3f0b6d4d4ce5c9e144ebbedf (patch)
tree4d7d122a6ea88d37a299164fcf038d75d745f2a3 /gnu/packages/web.scm
parent0f4030c4c6860806ef487c2b6d90fd9c599b64e7 (diff)
downloadguix-patches-d85edd7a9528fc9f3f0b6d4d4ce5c9e144ebbedf.tar
guix-patches-d85edd7a9528fc9f3f0b6d4d4ce5c9e144ebbedf.tar.gz
gnu: stunnel: Update to 5.58 [security fixes].
* gnu/packages/web.scm (stunnel): Update to 5.58.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e9a17f3b78..68fd9c4d11 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5813,14 +5813,14 @@ tools like SSH (Secure Shell) to reach the outside world.")
(define-public stunnel
(package
(name "stunnel")
- (version "5.57")
+ (version "5.58")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.stunnel.org/downloads/stunnel-"
version ".tar.gz"))
(sha256
- (base32 "1q8gc05fiz7w55ws0whwzb94ffjnhzfppf1mhz1hf671vmrvjnmg"))))
+ (base32 "0y9vjzjqi340vy6h321r1cskb7l6a4prr9d2ysixqzjpjv04rhfl"))))
(build-system gnu-build-system)
(native-inputs
;; For tests.
@@ -5847,6 +5847,8 @@ tools like SSH (Secure Shell) to reach the outside world.")
(substitute* "tests/make_test"
(("/bin/sh ")
(string-append (which "sh") " ")))
+ ;; test requires networking
+ (delete-file "tests/recipes/055_socket_closed")
#t)))))
(home-page "https://www.stunnel.org")
(synopsis "TLS proxy for clients or servers")