summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-31 11:04:51 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-31 11:04:51 +0100
commitce9383c090fff90acb3a555d0ccfe12d791fef17 (patch)
tree7b9cce156799486b94e4f3e55b03831638e73465 /gnu/packages/web.scm
parent91be09de61c277d0f1b26cefcefcd0a7fae2e00d (diff)
parentfc4eb87dc45b169e3912c73bbf60cb8ce76b7c7c (diff)
downloadguix-patches-ce9383c090fff90acb3a555d0ccfe12d791fef17.tar
guix-patches-ce9383c090fff90acb3a555d0ccfe12d791fef17.tar.gz
Merge remote-tracking branch 'master' into core-updates.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm90
1 files changed, 64 insertions, 26 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7595892283..b3d7d4c614 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -216,14 +216,14 @@ Interface} specification.")
;; ’stable’ and recommends that “in general you deploy the NGINX mainline
;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
;; Consider updating the nginx-documentation package together with this one.
- (version "1.17.6")
+ (version "1.17.7")
(source (origin
(method url-fetch)
(uri (string-append "https://nginx.org/download/nginx-"
version ".tar.gz"))
(sha256
(base32
- "1dipq90h3n1xdslwbijwlhbk84r7q0bswlbvi970may09lqsbd1w"))))
+ "1zwiqljhzf0ym6r3hrg6k2qfb2mxi7i0lpafg4xnkr875225c9xn"))))
(build-system gnu-build-system)
(inputs `(("openssl" ,openssl)
("pcre" ,pcre)
@@ -1518,7 +1518,7 @@ minimum to provide high performance operation.")
(define-public libsass
(package
(name "libsass")
- (version "3.5.5")
+ (version "3.6.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1527,7 +1527,7 @@ minimum to provide high performance operation.")
(file-name (git-file-name name version))
(sha256
(base32
- "0830pjcvhzxh6yixj82x5k5r1xnadjqzi16kp53213icbly0r9ma"))))
+ "1vn0q343d1vxz5q0xb6f9dzjah8z6j0s6x0lwvwdd55xa8z7rsnh"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1552,7 +1552,7 @@ stylesheets, you'll need to use another program that uses this library,
(define-public sassc
(package
(name "sassc")
- (version "3.5.0")
+ (version "3.6.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1561,7 +1561,7 @@ stylesheets, you'll need to use another program that uses this library,
(file-name (git-file-name name version))
(sha256
(base32
- "0jsfz1zg4gwk0dq8i92ll12axs3s70wsdsmdyi71zx8zmvib5nl6"))))
+ "1sxm54mkhs9m4vnl7vn11y17mhzamc403hv3966j1c7p2rbzg5pv"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -4196,8 +4196,8 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(package-with-python2 python-feedparser))
(define-public guix-data-service
- (let ((commit "af1324855e1ecaf9b1dd7afcc714d09aaa38f081")
- (revision "6"))
+ (let ((commit "82b797ee9869ebe24f7dbbcc56c3d500e75dc2d3")
+ (revision "13"))
(package
(name "guix-data-service")
(version (string-append "0.0.1-" revision "." (string-take commit 7)))
@@ -4209,7 +4209,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(file-name (git-file-name name version))
(sha256
(base32
- "1qxs1sbyx894njw4f898wzc5shjj85h9kgz95p8mq1acmazhlhkv"))))
+ "0m500f40b4dmw1nsjhci7v4jxk8fsn2pp0xkiw2s13rmdnqar31s"))))
(build-system gnu-build-system)
(arguments
'(#:modules ((guix build utils)
@@ -4253,6 +4253,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
"guix-data-service-process-branch-updated-mbox"
"guix-data-service-process-job"
"guix-data-service-process-jobs"
+ "guix-data-service-manage-build-servers"
"guix-data-service-query-build-servers"))
#t)))
(delete 'strip)))) ; As the .go files aren't compatible
@@ -4286,13 +4287,14 @@ PostgreSQL database.")
(name "gumbo-parser")
(version "0.10.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/google/"
- "gumbo-parser/archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/gumbo-parser")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1bgg2kbj311pqdzw2v33za7k66g1rv44kkvvnz2gnpaasi9k0ii8"))))
+ "0xslckwdh2i0g2qjsb6rnm8mjmbagvziz0hjlf7d1lbljfms1iw1"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f)) ;tests require bundling googletest sources
@@ -5370,16 +5372,17 @@ used to start services with both privileged and non-privileged port numbers.")
(version "5.6.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/htacg/tidy-html5/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/htacg/tidy-html5")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0n29wcgw32rhnraj9j21ibhwi0xagmmcskhbaz8ihxly7nx3p9h8"))))
+ "0w175c5d1babq0w1zzdzw9gl6iqbgyq58v8587s7srp05y3hwy9k"))))
(build-system cmake-build-system)
(outputs '("out"
- "static")) ; 1.0MiB of .a files
+ "static")) ; 1.3MiB of .a files
(arguments
`(#:tests? #f ; no tests available
#:build-type "Release"
@@ -5415,7 +5418,7 @@ functions of Tidy.")
(define-public hiawatha
(package
(name "hiawatha")
- (version "10.9")
+ (version "10.10")
(source
(origin
(method url-fetch)
@@ -5428,7 +5431,7 @@ functions of Tidy.")
(list "extra/nghttp2.tgz" "mbedtls"))
#t))
(sha256
- (base32 "1f2j2x1ziawz8ijg3s3izqpyzpiwfyhlsvbv0szxvhvj4a0l7pbl"))))
+ (base32 "1nd46cx1qp5lh2kwnn2mlwk9zm8jm7pgf90xs9vpwr7saxbnzr5m"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no tests included
@@ -6553,12 +6556,14 @@ container.")))
(name "java-jsoup")
(version "1.10.3")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/jhy/jsoup/archive/jsoup-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jhy/jsoup")
+ (commit (string-append "jsoup-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0xbzw7rjv7s4nz1xk9b2cnin6zkpaldmc3svk71waa7hhjgp0a20"))))
+ "1hdpdx0x140r5x3yc251v7dj1h4j5a7nh9k885aw9q5vvz49lkf4"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "jsoup.jar"
@@ -7011,3 +7016,36 @@ endpoint that will be used to trigger the task. Poussetaches makes HTTP
requests with the registered payload until the right status code is
returned.")
(license license:isc)))
+
+(define-public htmlcxx
+ (package
+ (name "htmlcxx")
+ (version "0.87")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://sourceforge/htmlcxx/v"
+ version "/htmlcxx-" version ".tar.gz"))
+ (sha256
+ (base32 "1j3mzjlczjrk4ahc43s6kzpvzypzjmqz4sillnca5yadrwwgjf2x"))))
+ (build-system gnu-build-system)
+ (home-page "http://htmlcxx.sourceforge.net/")
+ (synopsis "Simple non-validating CSS1 and HTML parser for C++")
+ (description "htmlcxx is a simple non-validating CSS1 and HTML parser for
+C++. Although there are several other HTML parsers available, htmlcxx has some
+characteristics that make it unique:
+@itemize
+@item STL like navigation of DOM tree, using excelent's tree.hh library from
+Kasper Peeters
+@item It is possible to reproduce exactly, character by character, the original
+document from the parse tree
+@item Bundled CSS parser
+@item Optional parsing of attributes
+@item C++ code that looks like C++ (not so true anymore)
+@item Offsets of tags/elements in the original document are stored in the nodes
+of the DOM tree
+@end itemize")
+ (license (list license:lgpl2.0
+ license:gpl2
+ license:asl2.0))))