summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-31 12:47:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-10-31 14:49:47 +0200
commitbc5155b952ae8bdbc56aded4d8d39768b4e2a7d4 (patch)
tree6b55475d86c522543384dea7d1ab66bba32af63e /gnu/packages/web.scm
parentdac8d013bd1fc7f57b8ba3582eef6e0e01b23dfd (diff)
parent4e5000114ec01b5e92a87c52f2a10f9ba7a601c8 (diff)
downloadguix-patches-bc5155b952ae8bdbc56aded4d8d39768b4e2a7d4.tar
guix-patches-bc5155b952ae8bdbc56aded4d8d39768b4e2a7d4.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index bb52eeab82..38be76d582 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -809,7 +809,7 @@ programming language.")))
;; The nginx source code is part of the module’s source.
(format #t "decompressing nginx source code~%")
(invoke "tar" "xvf" (assoc-ref inputs "nginx-sources")
- ;; This packages's LICENSE file would be
+ ;; This package's LICENSE file would be
;; overwritten with the one from nginx when
;; unpacking the nginx source, so rename the nginx
;; one when unpacking.
@@ -5805,28 +5805,29 @@ and similar services.")
(define-public darkhttpd
(package
(name "darkhttpd")
- (version "1.12")
+ (version "1.13")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://unix4lyfe.org/darkhttpd/darkhttpd-"
- version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emikulic/darkhttpd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0185wlyx4iqiwfigp1zvql14zw7gxfacncii3d15yaxk4av1f155"))))
+ (base32 "0w11xq160q9yyffv4mw9ncp1n0dl50d9plmwxb0yijaaxls9i4sk"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags '("CC=gcc")
+ `(#:make-flags
+ (list (string-append "CC=" ,(cc-for-target)))
#:tests? #f ; No test suite
#:phases
(modify-phases %standard-phases
- (delete 'configure)
+ (delete 'configure) ; no configure script
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(install-file "darkhttpd"
(string-append (assoc-ref outputs "out")
- "/bin"))
- #t)))))
+ "/bin")))))))
(synopsis "Simple static web server")
(description "darkhttpd is a simple static web server. It is
standalone and does not need inetd or ucspi-tcp. It does not need any
@@ -5837,20 +5838,19 @@ config files---you only have to specify the www root.")
(define-public goaccess
(package
(name "goaccess")
- (version "1.5.1")
+ (version "1.5.2")
(source (origin
(method url-fetch)
(uri (string-append "http://tar.goaccess.io/goaccess-"
version ".tar.gz"))
(sha256
(base32
- "03wp75n1krv8g643q00gcv1ikmzwwh8jjqmph0wxww1bwrw7whc8"))
+ "12hwmd9cn7yy7vj92110skjaslpxkn05msb9wj228qmjjf9jzkm0"))
(modules '((guix build utils)))
(snippet '(begin
(substitute* "src/error.h"
(("__DATE__") "\"1970-01-01\"")
- (("__TIME__") "\"00:00:00\""))
- #t))))
+ (("__TIME__") "\"00:00:00\""))))))
(build-system gnu-build-system)
(inputs
;; TODO: Add dependency on geoip-tools.