summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-06-28 15:22:43 +0200
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-06-30 15:16:09 +0200
commitb1c894b53fa86d39e7860da25852d6de84fe6801 (patch)
tree0fab82cd90821386deb489da9e5e4e32f1b01b06 /gnu/packages/web.scm
parenta7eaaec8c147b099ea9b85d64ef2ba4a3f710b5c (diff)
downloadguix-patches-b1c894b53fa86d39e7860da25852d6de84fe6801.tar
guix-patches-b1c894b53fa86d39e7860da25852d6de84fe6801.tar.gz
gnu: nghttp2: Support for the Hurd.
* gnu/packages/web.scm (nghttp2)[inputs]: When compiling for the Hurd, include openssl:static.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 292ccf5285..47b0c5c9fb 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7232,7 +7232,10 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
`(("jemalloc" ,jemalloc))) ; fight nghttpd{,x} heap fragmentation
("libev" ,libev)
("libxml2" ,libxml2) ; for ‘nghttp -a’
- ("openssl" ,openssl)))
+ ("openssl" ,openssl)
+ ,@(if (hurd-target?)
+ `(("openssl-static" ,openssl "static"))
+ '())))
(arguments
`(#:configure-flags
(list (string-append "--libdir=" (assoc-ref %outputs "lib") "/lib")