summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-11-21 19:45:44 +0000
committerChristopher Baines <mail@cbaines.net>2019-11-21 19:45:44 +0000
commita1136b6de015257e6d11ab91be0b78223b7d3b63 (patch)
treee8ff8ff52a1941d0fd56bb08e226e19afd0f0543 /gnu/packages/web.scm
parentf5dd0f5a45f45c57fb5837a431a97123fd82dc0d (diff)
downloadguix-patches-a1136b6de015257e6d11ab91be0b78223b7d3b63.tar
guix-patches-a1136b6de015257e6d11ab91be0b78223b7d3b63.tar.gz
gnu: guix-data-service: Fix build.
Use the new EMACSLOADPATH, rather than setting GUIX_ENVIRONMENT. This also allows changing emacs-no-x to emacs-minimal. * gnu/packages/web.scm (guix-data-service)[arguments]: Remove the 'set-GUIX_ENVIRONMENT phase. [native-inputs]: Replace emacs-with-modules with emacs-minimal and emacs-htmlize.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 297eb605da..daf0f7d3d1 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4213,12 +4213,6 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
#:test-target "check-with-tmp-database"
#:phases
(modify-phases %standard-phases
- (add-after 'set-paths 'set-GUIX_ENVIRONMENT
- (lambda* (#:key inputs #:allow-other-keys)
- ;; This means guix.el finds the Emacs modules
- (setenv "GUIX_ENVIRONMENT"
- (assoc-ref inputs "emacs-with-modules"))
- #t))
(add-before 'build 'set-GUILE_AUTO_COMPILE
(lambda _
;; To avoid errors relating to guild
@@ -4269,10 +4263,8 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
("autoconf" ,autoconf)
("automake" ,automake)
("ephemeralpg" ,ephemeralpg)
- ("emacs-with-modules" ,(directory-union
- "emacs-union"
- (list emacs-no-x
- emacs-htmlize)))
+ ("emacs-minimal" ,emacs-minimal)
+ ("emacs-htmlize" ,emacs-htmlize)
("pkg-config" ,pkg-config)))
(synopsis "Store and provide data about GNU Guix")
(description