summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-12-19 22:17:20 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-12-19 22:17:20 +0100
commit9b38d9b3b34edb55f7f42b72a611b39e5164cf9f (patch)
tree322d17840a4028785ccd2bb6f52e0ab5d2a164a5 /gnu/packages/web.scm
parent78bfbfb5a760719f6a36111bedb6c537661d3da3 (diff)
downloadguix-patches-9b38d9b3b34edb55f7f42b72a611b39e5164cf9f.tar
guix-patches-9b38d9b3b34edb55f7f42b72a611b39e5164cf9f.tar.gz
gnu: buku: Fix build.
* gnu/packages/web.scm (buku)[origin]: Drop file-name. [arguments]: Drop sanity-check. [inputs]: Add python-flask.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 9442b65439..c8d08b3fe6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7599,15 +7599,18 @@ HTTrack is fully configurable, and has an integrated help system.")
(origin
(method url-fetch)
(uri (pypi-uri "buku" version))
- (file-name (git-file-name name version))
(sha256
(base32 "1n4d1mkjyvzdxbyq067p1p9skb3iwx0msd86nzr224dlqrfh9675"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f)) ;FIXME: many tests need network access
+ `(#:tests? #f ; FIXME: many tests need network access
+ #:phases
+ (modify-phases %standard-phases
+ ;; XXX: missing inputs, e.g. python-flask-admin
+ (delete 'sanity-check))))
(inputs
(list python-beautifulsoup4 python-certifi python-cryptography
- python-html5lib python-urllib3))
+ python-flask python-html5lib python-urllib3))
(home-page "https://github.com/jarun/buku")
(synopsis "Bookmark manager")
(description