summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-13 22:52:25 +0200
committerMarius Bakke <marius@gnu.org>2020-06-13 22:52:25 +0200
commit8ab70bae52f8d4b6356ec3b8a88cebf9debe8520 (patch)
tree6e13e1de3c9addac9dad5d9f194c229baa3b59ab /gnu/packages/web.scm
parent9bc516bada71e1437d73971584bff5e72e053dbe (diff)
parent8ea91d05b0fd16a8dd42a53efee9b16991d581b9 (diff)
downloadguix-patches-8ab70bae52f8d4b6356ec3b8a88cebf9debe8520.tar
guix-patches-8ab70bae52f8d4b6356ec3b8a88cebf9debe8520.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm39
1 files changed, 26 insertions, 13 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f6a0fc2e44..8d1c668b8e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -769,7 +769,7 @@ data.")
(define-public json-c
(package
(name "json-c")
- (version "0.13.1")
+ (version "0.14")
(source (origin
(method url-fetch)
(uri (string-append
@@ -777,7 +777,29 @@ data.")
version ".tar.gz"))
(sha256
(base32
- "0ws8dz9nk8q2c0gbf66kg2r6mrkl7kamd3gpdv9zsyrz9n6n0zmq"))
+ "0w381krr99q5a2rypx4g437fa7gzgl82i64sgnrs6g5jr44dwxxk"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/json-c/json-c/wiki")
+ (synopsis "JSON implementation in C")
+ (description
+ "JSON-C implements a reference counting object model that allows you to
+easily construct JSON objects in C, output them as JSON-formatted strings and
+parse JSON-formatted strings back into the C representation of JSON objects.
+It aims to conform to RFC 7159.")
+ (license license:x11)))
+
+;; TODO: Remove these old versions when all dependents have been updated.
+(define-public json-c-0.13
+ (package
+ (inherit json-c)
+ (version "0.13.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0ws8dz9nk8q2c0gbf66kg2r6mrkl7kamd3gpdv9zsyrz9n6n0zmq"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -787,20 +809,11 @@ data.")
(set-file-time "config.h.in"
(stat "aclocal.m4"))
#t))))
- (build-system gnu-build-system)
- (home-page "https://github.com/json-c/json-c/wiki")
- (synopsis "JSON implementation in C")
- (description
- "JSON-C implements a reference counting object model that allows you to
-easily construct JSON objects in C, output them as JSON-formatted strings and
-parse JSON-formatted strings back into the C representation of JSON objects.
-It aims to conform to RFC 7159.")
- (license license:x11)))
+ (build-system gnu-build-system)))
-;; TODO: remove this old version when all dependents have been updated.
(define-public json-c-0.12
(package
- (inherit json-c)
+ (inherit json-c-0.13)
(version "0.12.1")
(source (origin
(method url-fetch)