summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-08 00:28:06 +0100
committerMarius Bakke <marius@gnu.org>2020-12-08 00:45:56 +0100
commit627b70e3ac8aade9744a998c28570fbb52b986a7 (patch)
tree48a22d8f2edbab3bc68e8d4acd9b3281d17220fa /gnu/packages/web.scm
parent63be1a7daeedbad31346127c52c3b96b9bc6fca8 (diff)
downloadguix-patches-627b70e3ac8aade9744a998c28570fbb52b986a7.tar
guix-patches-627b70e3ac8aade9744a998c28570fbb52b986a7.tar.gz
gnu: qoauth: Fix build failure.
Fixes <https://bugs.gnu.org/45031>. Reported by Distopico <distopico@riseup.net>. * gnu/packages/web.scm (qoauth)[arguments]: Add phase 'adjust-mkspecs-directory'.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 794e2c919d..5c52a32927 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1071,6 +1071,14 @@ instances, while JSON's objects will be mapped to @code{QVariantMap}.")
(substitute* "src/src.pro"
(("/lib64") "/lib"))
#t))
+ (add-after 'unpack 'adjust-mkspecs-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "src/src.pro"
+ ;; Do not attempt to install the .prf file into qtbase
+ ;; "lib/mkspecs/features", ref <https://bugs.gnu.org/45301>.
+ (("\\$\\$\\[QMAKE_MKSPECS\\]")
+ (string-append (assoc-ref outputs "out") "/lib/qt5/mkspecs")))
+ #t))
(delete 'configure) ; no configure script
(delete 'check) ; no test target
(add-before 'build 'qmake