summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-12-09 18:20:26 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-12-09 18:25:32 +0100
commit5f6a0019339d8ee06a3f0a9bbb5df672179fe57a (patch)
treeca5efd8ce1b637eecffeb24959b7c3ad5dcc8078 /gnu/packages/web.scm
parentacbf47a0676cad4d56801845047118e3fcd1c5f2 (diff)
downloadguix-patches-5f6a0019339d8ee06a3f0a9bbb5df672179fe57a.tar
guix-patches-5f6a0019339d8ee06a3f0a9bbb5df672179fe57a.tar.gz
gnu: Add kiwix-desktop.
* gnu/packages/web.scm (kiwix-desktop): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 97bff39718..6be6011c4e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7949,3 +7949,59 @@ for ZIM files.")
(description "The Kiwix library provides the Kiwix software suite core.
It contains the code shared by all Kiwix ports.")
(license license:gpl3)))
+
+(define-public kiwix-desktop
+ (package
+ (name "kiwix-desktop")
+ (version "2.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://download.kiwix.org/release/kiwix-desktop/kiwix-desktop-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1a9h4qmh6fkfscyp6lax0ri07dvvzw2wp4kr1sm86n0bdk3cwwha"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "qmake"
+ (string-append "PREFIX="
+ (assoc-ref outputs "out")))))
+ (add-before 'configrue 'enable-print-support
+ (lambda _
+ (substitute* "kiwix-desktop.pro"
+ (("webenginewidgets") "webenginewidgets printsupport"))
+ #t))
+ (add-before 'configure 'substitute-source
+ ;; Looks like .pro file is missing a feature.
+ ;; See https://github.com/kiwix/kiwix-desktop/issues/556.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "kiwix-desktop.pro"
+ (("webenginewidgets" all) (string-append all " printsupport")))
+ #t)))))
+ (inputs
+ `(("curl" ,curl)
+ ("icu4c" ,icu4c)
+ ("kiwix-lib" ,kiwix-lib)
+ ("libzim" ,libzim)
+ ("pugixml" ,pugixml)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebchannel" ,qtwebchannel)
+ ("qtwebengine" ,qtwebengine)
+ ("xapian" ,xapian)
+ ("zlib" ,zlib)
+ ("zstd" ,zstd "lib")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qmake" ,qtbase)))
+ (home-page "https://wiki.kiwix.org/wiki/Software")
+ (synopsis "Viewer and manager of ZIM files")
+ (description "Kiwix Desktop allows you to enjoy a lot of different content
+offline (such as Wikipedia), without any access to Internet.")
+ (license license:gpl3)))