summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-10 15:55:51 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-16 11:09:49 +0100
commit5f4621de1fc4ef99b6dd9cbc978e010168de67dd (patch)
treeaec2ed0ca37e2006c41166f5bf55c62682a46f41 /gnu/packages/web.scm
parentf106b0e970922cb5aad8fbb00375ad6a75f3f3d2 (diff)
downloadguix-patches-5f4621de1fc4ef99b6dd9cbc978e010168de67dd.tar
guix-patches-5f4621de1fc4ef99b6dd9cbc978e010168de67dd.tar.gz
gnu: Add r-curl.
* gnu/packages/web.scm (r-curl): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6a47f3b6c9..6c3329ffb6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -2978,3 +2978,28 @@ directory.")
various contexts including the R console, R Markdown documents, and Shiny web
applications.")
(license l:expat)))
+
+(define-public r-curl
+ (package
+ (name "r-curl")
+ (version "0.9.3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "curl" version))
+ (sha256
+ (base32
+ "02p9s1jlk8dcbvn71ivn4xnrqh9dwqyhgn4s1fzcfmnmfxhl5gld"))))
+ (build-system r-build-system)
+ (inputs
+ `(("libcurl" ,curl)))
+ (home-page "https://github.com/jeroenooms/curl")
+ (synopsis "HTTP client for R")
+ (description
+ "The @code{curl()} and @code{curl_download()} functions provide highly
+configurable drop-in replacements for base @code{url()} and
+@code{download.file()} with better performance, support for encryption, gzip
+compression, authentication, and other @code{libcurl} goodies. The core of
+the package implements a framework for performing fully customized requests
+where data can be processed either in memory, on disk, or streaming via the
+callback or connection interfaces.")
+ (license l:expat)))