summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-08 21:35:48 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-03 14:28:08 +0100
commit565df8a2678336ca527642fb575fde9046862093 (patch)
tree4f1340fe28682bd70f5f7863c6b6df66cf23a681 /gnu/packages/web.scm
parent2dd5b1e8b3ba5df830d6406b278e95319e104423 (diff)
downloadguix-patches-565df8a2678336ca527642fb575fde9046862093.tar
guix-patches-565df8a2678336ca527642fb575fde9046862093.tar.gz
gnu: Add qoauth.
* gnu/packages/web.scm (qoauth): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a0f46e3ee6..6f45072772 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -106,6 +106,7 @@
#:use-module (gnu packages jemalloc)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages kde)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libunistring)
@@ -829,6 +830,50 @@ instances, while JSON's objects will be mapped to @code{QVariantMap}.")
;; Only version 2.1 of the license
(license license:lgpl2.1)))
+(define-public qoauth
+ (package
+ (name "qoauth")
+ (version "2.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ayoy/qoauth.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1b2jdqs526ac635yb2whm049spcsk7almnnr6r5b4yqhq922anw3"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("qca" ,qca)
+ ("qtbase" ,qtbase)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-code
+ (lambda _
+ (make-file-writable "src/qoauth.pc")
+ (substitute* "src/src.pro"
+ (("/lib64") "/lib"))
+ #t))
+ (delete 'configure) ; no configure script
+ (delete 'check) ; no test target
+ (add-before 'build 'qmake
+ (lambda _
+ (let ((qca (assoc-ref %build-inputs "qca")))
+ (invoke
+ "qmake"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "QMAKE_INCDIR+=" qca "/include/Qca-qt5/QtCrypto")
+ (string-append "LIBS+=-L" qca "/lib")
+ (string-append "LIBS+=-lqca-qt5"))))))))
+ (home-page "https://github.com/ayoy/qoauth")
+ (synopsis "Qt-based C++ library for OAuth authorization scheme")
+ (description "QOAuth is an attempt to support interaction with
+OAuth-powered network services in a Qt way, i.e. simply, clearly and
+efficiently. It gives the application developer no more than 4 methods.")
+ (license license:lgpl2.1+)))
+
(define-public krona-tools
(package
(name "krona-tools")