summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-03 15:45:44 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-03 15:45:44 +0100
commit52665d2b6bd709ba46c1e364a6d6164f5f4824ff (patch)
tree55fd79b3939c08f6f6e9fe383f0df5e4caa82b57 /gnu/packages/web.scm
parent584d08c5c98cb1893e4f44bd1c4191f405b13f01 (diff)
parent0a83339bb1429332ee889e9a976aa214ae2ac0db (diff)
downloadguix-patches-52665d2b6bd709ba46c1e364a6d6164f5f4824ff.tar
guix-patches-52665d2b6bd709ba46c1e364a6d6164f5f4824ff.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm87
1 files changed, 81 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 00387ed899..2336555829 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
+;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -108,6 +109,7 @@
#:use-module (gnu packages jemalloc)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages kde)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libunistring)
@@ -831,6 +833,50 @@ instances, while JSON's objects will be mapped to @code{QVariantMap}.")
;; Only version 2.1 of the license
(license license:lgpl2.1)))
+(define-public qoauth
+ (package
+ (name "qoauth")
+ (version "2.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ayoy/qoauth.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1b2jdqs526ac635yb2whm049spcsk7almnnr6r5b4yqhq922anw3"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("qca" ,qca)
+ ("qtbase" ,qtbase)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-code
+ (lambda _
+ (make-file-writable "src/qoauth.pc")
+ (substitute* "src/src.pro"
+ (("/lib64") "/lib"))
+ #t))
+ (delete 'configure) ; no configure script
+ (delete 'check) ; no test target
+ (add-before 'build 'qmake
+ (lambda _
+ (let ((qca (assoc-ref %build-inputs "qca")))
+ (invoke
+ "qmake"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "QMAKE_INCDIR+=" qca "/include/Qca-qt5/QtCrypto")
+ (string-append "LIBS+=-L" qca "/lib")
+ (string-append "LIBS+=-lqca-qt5"))))))))
+ (home-page "https://github.com/ayoy/qoauth")
+ (synopsis "Qt-based C++ library for OAuth authorization scheme")
+ (description "QOAuth is an attempt to support interaction with
+OAuth-powered network services in a Qt way, i.e. simply, clearly and
+efficiently. It gives the application developer no more than 4 methods.")
+ (license license:lgpl2.1+)))
+
(define-public krona-tools
(package
(name "krona-tools")
@@ -1097,6 +1143,36 @@ implementation that is simple, portable, flexible, lightweight, low level, and
high performance.")
(license license:bsd-3)))
+(define-public wslay
+ (package
+ (name "wslay")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tatsuhiro-t/wslay.git")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ak9a6hsanhys40yhv7c2gqkfghpm6jx36j1pnml8ajvgaky5q98"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("cunit" ,cunit) ; For tests.
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("python-sphinx" ,python-sphinx)))
+ (home-page "https://tatsuhiro-t.github.io/wslay/")
+ (synopsis "C WebSocket library")
+ (description "@code{Wslay} is an event-based C library for the WebSocket
+protocol version 13, described in RFC 6455. Besides a high-level API it
+provides callbacks for sending and receiving frames directly. @code{Wslay}
+only supports the data transfer part of WebSocket protocol and does not
+perform the opening handshake in HTTP.")
+ (license license:expat)))
+
(define-public libpsl
(package
(name "libpsl")
@@ -5030,21 +5106,20 @@ w3c webidl files and a binding configuration file.")
(delete 'configure)
(add-after 'build 'adjust-welcome
(lambda _
- ;; First, fix some unended tags and simple substitutions
(substitute* "frontends/gtk/res/welcome.html"
+ ;; Close some XHTML tags.
(("<(img|input)([^>]*)>" _ tag contents)
(string-append "<" tag contents " />"))
- (("Licence") "License") ;prefer GNU spelling
+ ;; Increase freedom.
((" open source") ", free software")
- (("web&nbsp;site") "website")
- ;; Prefer privacy-respecting default search engine
+ ;; Prefer a more privacy-respecting default search engine.
(("www.google.co.uk") "www.duckduckgo.com/html")
(("Google Search") "DuckDuckGo Search")
(("name=\"btnG\"") ""))
- ;; Remove default links so it doesn't seem we're endorsing them
+ ;; Remove default links so it doesn't seem we're endorsing them.
(with-atomic-file-replacement "frontends/gtk/res/welcome.html"
(lambda (in out)
- ;; Leave the DOCTYPE header as is
+ ;; Leave the DOCTYPE header as is.
(display (read-line in 'concat) out)
(sxml->xml
(let rec ((sxml (xml->sxml in)))